Session timeout - no config available

OK So we have latest Pydio Cells 2.2.12 (Home) installed on Windows server 2016 (hosted on VPS) but the user session timeout is rather short (no more than 1 or 2 mins) but there doesn’t appear to be any available config possible. The only previous query on this matter [solved] Can the inactive timeout be changed? appears to be out of date and for Pydio 8. I can find no such config available in the plugins and indeed most of the plugins cannot be configured (either toggle greyed out or clicking the settings icon opens a blank pop up window, not sure if this is expected or not). I can find no reference in the documentation or command reference or any config in the main .json config file. So, can this session inactivity timeout be adjusted?

1 Like

Hi @AndyS,
This 1mn long session seems buggy in fact. Can you check that your server time is properly synchronized ?

Thanks for the reply, yes the server is in sync with NTP and I checked to ensure that was indeed the case. Anything else to be checked from our end?

I’m watching eagerly for an answer… one of my users complains about exactly the same issue, and the only thing I could do was to increase timeouts at the reverse proxy level (nginx), but it seems to have little to no effect (this particular user, for some reason, is unable to launch Pydio Sync, so he has no other option but to use the web interface).

1 Like

@GwynethLlewelyn => if you have one specific user having issues, did you check that his computer clock is properly synced ? @AndyS same for you on the client side ?

Yep I did of course check this when NTP was first suggested, it’s exactly in sync (you can see server and client seconds synced to the millisecond)

OK so looks like it was just basic server 101, IIS session timeout set too low! :stuck_out_tongue_closed_eyes:
upped to to 240 in Limits and now get more useful session limit timeout. @GwynethLlewelyn hopefully it’s the same on your end? Although you said this only impacts one particular user… :thinking: