Renaming a file does not refresh on the UI for some cases


Give me a few days, i’ll write a summary :wink:


@charles Sorry for the delay, here is a little how-to to reproduce the environment (in a VM for example), so you’ll be able to investigate :

Install Debian 9.8 from ISO

(SSH server + upgrade)

apt-get update; apt-get upgrade -y

Install MariaDB 10.3

apt-get install -y software-properties-common dirmngr curl
curl -sS | bash -s -- --mariadb-server-version="mariadb-10.3"
apt-get update
apt-get install -y mariadb-server mariadb-client
systemctl enable mysql
systemctl status mysql

Install Docker

apt-get install -y apt-transport-https curl
echo 'deb [arch=amd64] stretch stable' > /etc/apt/sources.list.d/docker.list
curl -fsSL | apt-key add -
apt-get update
apt-get install -y docker-ce
systemctl enable docker
systemctl status docker

Create database

mysql -p -e 'CREATE DATABASE cells; GRANT ALL PRIVILEGES ON cells.* TO cells@localhost IDENTIFIED BY "cells"; FLUSH PRIVILEGES;'

Start Cells container

(my host IP is

docker pull pydio/cells
docker run -dit --restart unless-stopped \
  -p 8080:8080 \
  -v /var/run/mysqld:/var/run/mysqld \
  -e CELLS_BIND= \
  -e CELLS_NO_SSL=1 \
  --name cells pydio/cells

Install Cells
Use mysql socket : /var/run/mysqld/mysqld.sock


(problem is still present in 1.4.1)

At the end of the video the test.txt file is:

  • test4.txt on the filesystem (good)
  • test3.txt on the webui (wrong)


(disabling bin_logs = no replication)

sed -i 's;^\(log\_bin.*mariadb\-bin\)$;\#\1;g' /etc/mysql/my.cnf
sed -i 's;^\(log\_bin\_index.*mariadb\-bin\.index\)$;\#\1;g' /etc/mysql/my.cnf
sed -i 's;^\(expire\_logs\_days.*\)$;\#\1;g' /etc/mysql/my.cnf
sed -i 's;^\(max\_binlog\_size.*\)$;\#\1;g' /etc/mysql/my.cnf
systemctl restart mysql
docker restart cells