Renaming a file does not refresh on the UI for some cases


#21

that’s nice,
i’ll still try your setup to be sure of the error and if it’s something that is constantly appearing, then we can add it as a bug.


#22

Ok, let me know if you find something !
I confirm on my 2 servers and my local VM that it’s working after disabling MariaDB bin log …
I’m pretty sure you can easily reproduce it on your side to deal with it. Let me know if you want more information or test.
And thank you for your help looking into this issue.


#23

On debian this gave me mariadb 10.1 which is not completly compatible,
could you try with this to install it
https://downloads.mariadb.org/mariadb/repositories/#distro=Debian&version=10.3&mirror=ovh&distro_release=stretch--stretch

edit: after testing mariadb 10.3 + cells docker on debian 9 stretch it worked perfectly.


#24

This should replace Debian’s MariaDB 10.1 with MariaDB 10.3 from repo:
curl -sS https://downloads.mariadb.com/MariaDB/mariadb_repo_setup | bash -s -- --mariadb-server-version="mariadb-10.3"

I’m so surprised you tell me it works, I have now 3 servers set-up with this and I can reproduce the problem every time if I dont disable log_bin in my.cnf


#25

yeah i don’t know why but it worked for me,
here’s my config :

z@debian:~$ mysql --version
mysql  Ver 15.1 Distrib 10.3.12-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
z@debian:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 9.8 (stretch)
Release:	9.8
Codename:	stretch
z@debian:~$ docker ps
CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                    NAMES
b30caf253d87        pydio/cells         "docker-entrypoint.s…"   2 hours ago         Up About a minute   0.0.0.0:8080->8080/tcp   cells

#26

All the same for me !

~# mysql --version
mysql  Ver 15.1 Distrib 10.3.12-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.8 (stretch)
Release:        9.8
Codename:       stretch

~# docker ps
CONTAINER ID        IMAGE                     COMMAND                  CREATED             STATUS                  PORTS                                                   NAMES
c2bfe38091ef        pydio/cells               "docker-entrypoint.s…"   5 hours ago         Up 3 minutes            0.0.0.0:8082->8082/tcp                                  cells
ca41333dacb6        collabora/code            "/bin/sh -c 'bash st…"   24 hours ago        Up 23 hours             0.0.0.0:9980->9980/tcp                                  lool

Can you please confirm MariaDB binary log is enabled?

~# grep log_bin /etc/mysql/my.cnf
log_bin                        = /var/log/mysql/mariadb-bin
log_bin_index          = /var/log/mysql/mariadb-bin.index

~# ls -l /var/log/mysql/
-rw-rw---- 1 mysql adm 31339 Feb 20 21:36 mariadb-bin.000001
-rw-rw---- 1 mysql adm    34 Feb 20 21:35 mariadb-bin.index
-rw-rw---- 1 mysql adm     8 Feb 20 21:36 mariadb-bin.state

Updated to v1.4.0 today: same situation when bin_log is ON.


#27

Hi,

here’s the command result, of my db container.

root@644ab11e10dc:/# grep log_bin /etc/mysql/my.cnf
#log_bin			= /var/log/mysql/mariadb-bin
#log_bin_index		= /var/log/mysql/mariadb-bin.index

#28

Ok, here is why you are not able to reproduce the problem!

You need to enable binary log by removing ‘#’ at start of these two lines.
Restart MariaDB (or container) and check the “/var/log/mysql” directory is writing logs.

Then, you will be able to reproduce.

Note: bin_logs are required for MariaDB replication.


#29

yeah,
let me try with those on.


#30

actually nevermind i checked on the wrong server (it was a container),
but on the debian 9 they are indeed enabled,

#auto_increment_offset  = 1
log_bin                 = /var/log/mysql/mariadb-bin
log_bin_index           = /var/log/mysql/mariadb-bin.index

#31

i think i’ve just managed to reproduce your case,
let me test once more.

edit: i tested a lot and i can make it happen but i have cases where it does not happen after i renamed 2/3 times then it starts doing it.


#32

The first rename after starting Cells is usually working, not the others.


#33

yeah seems so,
i started a cell and did not stop it, but if i create a file i can rename it twice before it does it,
if i create another file i can also rename it twice before it appears.


#34

I’m happy you were able to reproduce the problem.
So next step (the more difficult I guess) : find the root cause and fix it :wink:


#35

This could be caused by delayed commits - the default DB server settings may differ between distributions versions (you mentioned that there are no issues in some combinations ). No issues here with Cells 1.4.0, OL7.6, MySQL 5.6.43. Can you post the output of “show variables” of one that does cause issues?


#36

Here the default variables for Debian 9 using MariaDB 10.3 (from MariaDB’s repo):
https://pastebin.com/raw/tgK6WgMk (too big to be posted in the forum)

I just made two changes:

  • data dir = /home/mysql
  • max_connections = 500

#37

The settings look fine so far - I could not identify anything that could cause the issues.
For the data_dir - do you have SElinux enabled (enforcing) ? Could you please run the below commands and post the output?

sestatus
ls -Zd /home/mysql
ls -Zd /var/log/mysql

I doubt that this would cause the issues you reported but will allow to eliminate this is a possible cause.
Is /var/log/mysql the default for log_bin on your platform ? Usualy these are stored in data_dir as well.


#38

No problem with SElinux, I’m on Debian 9 (there is no SElinux and AppArmor is disabled by default).

Custom data directory is also not the problem here, I was able to reproduce with Debian default directories (vanilla config):

  • data = /var/lib/mysql
  • log = /var/log/mysql

#39

Does somebody have any new idea ?


#40

Hi @dam09fr the thread is a bit messy now.
Can you write a summary of what’s exactly happening? Is it eventually possible to access your server?