Cells - Timeout of 60000ms exceeded during login


#1

This would appear at first glance to be a database connectivity issue but the database is installed (as verified by logging into the database server and checking that the tables were created).

Advise on how to resolve?

There appears to be nothing in the docker logs.


#2

Hi,
could you tell me the context of the error,
and also i would like to know your setup (if it’s docker, database etc…).

Regards


#3

Using docker/compose per https://hub.docker.com/r/pydio/cells however, with the following modifications:

services.cells.enviroment

  • CELLS_BIND=0.0.0.0:8080
  • CELLS_EXTERNAL=192.168.X.X:8080

services.db.image: mariadb:10.2

where X merely indicates the part of the IP not disclosed above.

docker info:
Server Version: 18.06.1-ce
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 1018
Dirperm1 Supported: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local local-persist
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 468a545b9edcd5932818eb9de8e72413e616e86e
runc version: 69663f0bd4b60df09991c08812a60108003fa340
init version: fec3683
Security Options:
apparmor
Kernel Version: 3.13.0-149-generic
Operating System: Ubuntu 14.04.5 LTS
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.791GiB
Name: Koinonia
ID: GBSZ:F4QY:L4ZP:O764:RSTI:AWQL:UXTN:DRON:TZRR:6FKC:TMTS:T4U2
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: true


#4

Hi,
and if you do a docker logs -f <your cells container>, what does it say?

i used this docker-compose and i did not encounter the error,

version: '3'
services:

    # Cells image with two named volumes for the static and for the data
    cells:
        image: pydio/cells:latest
        volumes: ["data:/root/.config/pydio/cells/data"]
        ports: ["8080:8080"]
        environment:
            - CELLS_BIND=0.0.0.0:8080
            - CELLS_EXTERNAL=192.168.0.109:8080
            - CELLS_NO_SSL=1

    
    mysql:
         image: mariadb:10.2
         environment:
             MYSQL_ROOT_PASSWORD: root
             MYSQL_DATABASE: cells
         ports: ["3306:3306"]
         
volumes:
    data: {}

If you want to show me your compose file, so that i try it.


#5

I’m getting a different failure now. Where is the database host setting in cells?


#6

See /root/.config/pydio/cells/pydio.json