Remote Auth wordpress - user created but cant log in


#1

Hello,

I’m on pydio 8.2.0, trying to get a bridge between my wordpress website and pydio I installed the plugin for wordpress and set the remote authentication.

When I login with a user in wordpress the account in pydio is created but there is no automatic login / i’m not able to login with that account if I use the same password set in wordpress.

I have set the master to remote auth and the slave to DB auth Storage

Multiple instances mode is set to Master/salve and User listing to Both

When I use only Master all my users are gone users from Wordpress are also created in the Slave database…
(AJXP_DATA_PATH/plugins/auth.serial/users.ser ) is this is where things go wrong?

I find ti strange that the user is created with the role set in the slave and not in the Master auth.

I would be grateful with some help because the doc file was not enough for me


#2

Hi,
could you tell me where did you get the bridge plugin and also it’s version.


#3

https://pydio.com/en/docs/kb/authentication/authentication-your-cms this tutorial
https://pydio.com/en/component/cms-bridges --> plugin download

I do not know if this is still up to date because it does not seem to work fully


#4

Hi,
so you are using the bridge 4.0.3 and what is your wordpress version ?


#5

correct thats the last one I could find. Is there a newer version?


#6

hi,
no there is no new version release right now.
Version 4.0.3 should be the last one.


#7

So what could be the error that the user is made but cant login?


#8

I will reproduce that to see if it happens to me, that’s why i had to ask you for the wordpress version and the bridge version.
I will keep you updated as soon as i have a piece of information.


#9

Update : i reproduced the case and it seems to be working so far, could you show me what you put in the forms of the master remote, and also could you give the field of the pydio path in your wordpress.

Screen captures would be great, just do not forget to remove the secret key.


#10

![33|690x200]

The wordpress is https://prismix.be the pydio is on a subdomain fileshare.prismix.be could that be the problem?


#11


#12

Hi,
sorry for the late reply, did you try with the auto create user disabled ?


#13

I have deactivated auto create, when I log in to wordpress with an account there is still an account created inside Pydio. When I surf to the Url I am still presented with the login form but the password from wordpress is not working.

What I want to become is that whenever they login to wordpress they do not have to login to pydio / or if they login to pydio they can do that with the same password as set in wordpress.