[solved] Disabled auth module - can't login. Help!


running pydio 8.0.1.
First auth method is serial, as second I added auth.remote.
Unfortunately, I deactived the auth.remote plugin afterwards in the backend.

Now I only get this error:
You have selected a disabled plugin (remote) for type ‘auth’.

I already edited:
PYDIO/plugins/auth.remote/manifest.xml >> line 2 >> enabled=”true”, set to true, was false.
Cleared *.ser in /var/lib/pydio/data/cache

In the database table “ajxp_plugin_configs” was no occurance of auth.remote, so I tried to add:
auth.remote | a:1:{s:19:“AJXP_PLUGIN_ENABLED”;b:1;}
as mentioned in this post:
But it had no effect either.

Please does somebody have an idea??
It a working system for a client :confused:
Best regards,

Hi Jan,

You can use these commands :
1 - Restore backup configuration from
/var/lib/pydio/data/plugins/boot.conf/bootstrap.json.bak to /var/lib/pydio/data/plugins/boot.conf/bootstrap.json
And the parameters AJXP_PLUGIN_ENABLED is true:
2 - Pydio: clear plugins cache
rm -rf /var/lib/pydio/data/cache/plugins_*
rm -rf /var/lib/pydio/data/cache/i18/*.ser

I hope it’s ok with that ;).

1 Like

Yes, the bootstrap.json still had the false-attribute.
Changing that to true solved the problem.
Not quite easy to find :wink: