Pydio Cells 1.4.0 not working with SMB mounted


#1

We have a Debian 9 server which was running Cells 1.2.2, had cells data mounted at /mnt/data/pydio/.
Additional to that we have 2 network shares mounted via smb/cifs to /mnt/data/pydio/data1, /mnt/data/pydio/data2, all lover caps and one word, and Cells worked normally.

Yesterday we upgraded to 1.4.0 and Cells became unresponsive, can’t access workspaces, can’t add folders and files, …
After we unmounted network shares and restarted Cells we regained normal functionality. Tested it few times and every time same behavior. Cells is broken when remote shares are mounted.

Does anyone else have similar problem?


#2

Hi,
when you say unmounted the shares, does it mean that you just unmounted the folder or disabled the datasource.


#3

Unmounted the folders so they are no longer attached to the server via cifs/smb on OS level, and restarted Cells.
Currently they are not even configured as datasources, they break Cells just by being mounted on OS level in the folder designated for Cells datasources.


#4

let me reproduce that,
Just to make it clear,
you have 2 samba shares mounted and used for 2 datasources?


#5

I have 2 samba shares mounted in Pydio Cells datasources folder that is correct.
Currently they are not used as datasources they are just mounted there, but we would like to use them as datasources.


#6

understood,
i’m on it i will try to reproduce your exact case and come back to you with what i get.


#7

This is with shares mounted:

|2019-03-01T13:04:37.756+0100|ERROR|pydio.grpc.data.sync.cellsdata|Could not run |{“error”: “objects not reachable”}|
|2019-03-01T13:04:37.972+0100|ERROR|pydio.grpc.data.sync.test|Could not run |{“error”: “objects not reachable”}|
|2019-03-01T13:04:38.549+0100|ERROR|pydio.grpc.data.sync.personal|Could not run |{“error”: “objects not reachable”}|
|2019-03-01T13:04:38.635+0100|ERROR|pydio.grpc.data.sync.pydiods1|Could not run |{“error”: “objects not reachable”}|


#8

If the datasource server cannot reach the shares(folders) and therefore sync, this should happen,
you could notice inside your folder where the datasource is pointing a .minio.sys folder.


#9

When I unmount shared folder those local folders become available again:

|2019-03-01T13:09:23.955+0100|INFO|pydio.grpc.data.sync.pydiods1|Sending event to start datasource resync|
|2019-03-01T13:09:24.008+0100|INFO|pydio.grpc.data.sync.test|Sending event to start datasource resync|
|2019-03-01T13:09:24.228+0100|INFO|pydio.grpc.data.sync.cellsdata|Sending event to start datasource resync|
|2019-03-01T13:09:24.316+0100|INFO|pydio.grpc.data.sync.personal|Sending event to start datasource resync|


#10

I see .minio.sys folder in the datasource folder where local folders are located, and where the network shares are mounted, when they are mounted.

ls -alh

binaries
cellsdata
data1 <- network mount
data2 <- network mount
.minio.sys
personal
pydiods1
test
thumbs
versions


#11

could you do a pwd of the location that you ls above.


#12

/mnt/data/pydio/ as mentioned in first post.
It was specified that way during installation when there was an option to chose location.


#13

ah yes my bad,
i’ll do that setup.

edit: sorry i have something on my hands for the time being but i’ll try to handle your case whenever i can.


#14

Any news?
Is this problem related to this?


#15

Hi,
it could be related to that,
i tried with samba shares mounted directly like you setup, i also tried to mount and use symbolic links to mounted to the samba shares (of course set my rights on the samba shares) and did not manage to make it work.

it was with 1.4.0,
now i’m gonna take a look at 1.2.2 to see what i get.

Maybe my guess would be that you mount your samba share somewhere else and then use a symbolic link if you want to access the data with cells.


#16

You did not manage to make cells work or you did not manage to reproduce my problems?


#17

I did not manage to make the smb work, i had cells running but when i tried using smb mounted datasources i did not manage to use it.


#18

Aha, OK, then same as my problem.
1.2.2 should work.


#19

Any news with 1.4.x and SMB?


#20

Hi,
so basically after testing, i realized that because we write a .minio.sys in the parent folder your datasources must point to alteast 1 level inside the sambashare for instance,
/mnt/data/smbshare/ and make the datasource point to it,
that is to make a samba share volume work.