Public link issues with Pydio 7.0.4

I’m having trouble getting public links to work on my pydio 7.0.4 install. I get the ‘Oups, cannot find this page’ error.
I’ve set Pulic Base URI to /pydio/public and the download URL to . I’ve cleared the cache files plugin*.ser in /var/cache/pydio . Rewrite is set to /pydio , Everything seems to work on pydio except the public links. If I create a custom link, I get an error in the logs but if I do not there is no error. This is on a Centos 7 install.
date ip level user action source params cursor text ajxp_im_time

11-02-17 15:48:30 ERROR shared error l.70 SecureTokenMiddleware.php message=You are not allowed to access this resource. 9805 11-02-17 15:48:30 1509638922


First, welcome to new platform.
Concerning to this issue, could you please try to rename /var/lib/pydio/public to /var/lib/pydio/public.backup

Hello! Thank you very much for the invite to the new forum!

I made the change and the result was the same. I get the ‘Oups, cannot find this page’ . No error in the logs.


Could you please post your .htaccess in root of Pydio, also config of virtualhost

Sorry for the pictures, the forum was messing up the formatting if I just pasted it in.

From what I’ve seen online, I may need to clear cache in the sql db. Thoughts?

Make sure the param in Pydio >> Settings like …

My settings are:
Public Base URI: /public
Download location (legacy): (blank, I am running 7.0.4)
Download URL:

I left the Download location empty as thats what your documentation says unless I upgraded from pydio 6, and I did not upgrade.

I am now getting a blank page when I try to share a file.

The log shows the user logging in successfully when I try to get the file using the public link.

I tried setting the download location. I made a folder, gave apache access, and set the location in pydio. Still same results, blank page.

Any thing I should try?

please email me ( for a quick Teamviewer

The problem is :slightly_smiling_face:
There exist a folder public in /pydio => so the request to public link …/pydio/public/abcdefgh will be route to /pydio/public folder instead of going to index.php by rewrite

Solution: remove public folder or rename to public.bak