Problem with storage syncing

Hello, I got pydio 2.2.2 inside docker container. I’m using cells-sync on two computers. Once a week I got problem with creating folders in personal area and file syncronisation.

  1. I just log inside web UI, trying to create new folder. It created in the file system, but not in pydio.
  2. I update files on machine 1 and they are not uploaded to pydio. No syncing starting.

Manual storage resync inside pydio console solves both problems. How can I fix this? Is this a docker related issue?

Might or might not. From what you are describing, it seems that you have a problem with your index. This can have various root causes:

  • Performance issue: do you monitor your RAM and CPU? Is your machine large enough ?
  • Unreliable connection to DB (this might depends on docker): is your DB on the same machine, Docker setup, … ? Are you hitting the max_connection limit ?
  • Corrupted index: when you have many files, and furthermore with the Cells Sync Client enabled, it happens that the index got corrupted. This might lead to the behavior you describe:
    • Do you see error / warning messages when you run the resync of the datasource ?
    • For the record, the last hotfix release focus was auto-healing processes of the indexes for such situation, might be a good idea to upgrade.

With so little info about your setup and without system’s hints (Do you see error in the logs, both in the server and in the sync client when you perform your buggy actions? ), it is difficult to answer this.

Hi, bsinou

I run everything in docker container (docker-compose). Server has no performance issues (8 CPU CORES, 128GB RAM). At the moment I’m testing pydio and in my test account I haveonly five files.

Can it be a watchers problem or something? I don’t know how pydio works, but usually watchers is the problem in docker

UPD: No errors in logs

Hi,
may be it is something wrong in configuration? What I’ve got:
1 server with pydio and 3 desktops. Sometimes cells-sync on one pc thoughts that It already synced to latest version, but actually not. If I tun storage resync on server it updates index (or something) and after that cells syncing to latest version. Am I wrong thinking that it’s wrong? What should I check?

On those desktops I use linux version of cells-sync

Just to be sure, the 3 desktops sync clients are:

  • using same user and trying to sync the same workspace / folder in the server

OR

  • each connecting with a different user and syncing a distinct folder ?

Same user and same folder.

Storage in the filesystem (inside docker volume) and versioning is on. Maybe it makes sense

hmm. OK. I think we might have a leading trail here:
We know the sync is not totally bullet proof (hence the 0.9.2 version) and some use cases still need to be hardened.
So I suppose it get confused when then various clients try to synchronise the same target.

I assume the target folder on the server is in the “Personal File” folder, right ? It would be nice if you can give some details the exact tree structure that leads to this faulty behaviour:
we would like to be able to reproduce it on our side to dig the issue and solve it.

Structure is very simple:

some_folder/
  some_folder2/
    some_file3
    some_file4
  some_file1
  some_file2

So I got 3 PCs with Ubuntu 20.04. All running cell-sync. PC’s caт be suspended. Two of them are shutted down every day, one works 24/7. I do some work on PC1, sync files. Move to PC2, start cells-sync and can’t find those files, but they are present in web UI. I run full resync on PC2, It does not help.
But If i run storage resync on the server, everything works.

Sometimes I sync files and they are not present in web UI. Once I got this error when I try to create new folder using WEB UI. Folder created on the filesystem, but was not present in web.