Origin is not allowed by Access-Control-Allow-Origin Windows 2016 Cells v2.2.2

I decided to post a new thread since the one that I found showed solved. I thought is people saw that they would ignore it.

I installed this on a new Windows 2016 server and am getting the error “Origin is not allowed by Access-Control-Allow-Origin” but I can’t get into it to adjust the settings mentioned here. How can I resolve this? Any assistance is appreciated.

Forgot, i am using MariaDB and 2.2.2 Cells.

Hello @ecold
It’s hard to give you any useful piece of advice without knowing anything about your setup. For this kind of error, please give us your network settings : output of cells configure sites command ? How do you access to Cells (which URL)?

Thank you for your help, below is some additional info.
It came up as but this never worked. I tried which is where I encountered the error after attempting to log in. This now does not come up.
My public IP does not and has not worked. My main thought was it should work on before I worry about anything else. I have tried these with and without the firewall on.
Where do I go to run the command you provided?

And you do try to login with ? Do you try to access the server from the outside world or only on the same machine for the moment?

The command is to be run directly in the command line, where you have put the cells binary.

Ok, some progress, didn’t realize i had to use the original executable to run the commands. Once I figured that out i ran the command and it only showed I added the public and localhost and am in with localhost. Public not working but I assume the installer doesn’t set the firewall rules so I can do that. However, my command window is still up and I keep seeing stopping and starting Caddy Instance, like every second or two. how do I resolve that?

This topic was automatically closed 35 days after the last reply. New replies are no longer allowed.