[SOLVED] Cells: Origin is not allowed Access-Control-Allow-Origin

Installation type: New install
Docker repository with docker-compose.yml, behind a Traefik reverse proxy
Debian 9
Pydio version: 1.0.2 2018-07-03

I manage to install Cells just fine via docker, but after the installation completes and then I login, I am getting some sort of further error. It seems to appear on pages that are loading external information (i.e. when setting up a user, the Country pick list will not load; on the Storage config, the error continually recurs at the bottom of the page.

The error that comes up looks like this:

Maybe I have some basic issue due to using Traefik? In caddy_errors.log I do see:
[ERROR 502 /] write tcp> write: broken pipe

My Traefik logs show no errors.

I managed to fix this issue by going to:
Settings -> Configs Backends
and replaced the REST Endpoints address, which was internal to Traefik, with the external to the world equivalent

I had first tried setting the Replace Host header for S3 signature to the internal IP like it says in the docs, but this didn’t work.

1 Like

I installed this on a new Windows 2016 server and am getting the error “Origin is not allowed by Access-Control-Allow-Origin” but I can’t get into it to adjust the settings mentioned here. How can I resolve this? Any assistance is appreciated.

Forgot, i am using MariaDB and 2.2.2 Cells.