Running Cells behind an Apache reverse proxy

hi,
the login page required from the proxy server remains blocked.

the browser console reports:
login:1 Access to fetch at ‘http://xxx.xxx.xxx.xxx:8080/plug/gui.ajax/res/build/pydio.min.js?v=c822d61f0ac40d85b7a5785e196c94c4’ from origin ‘http://xxx.xxx.xxx.xxx’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

pydio works normally if you use the installation url xxx.xxx.xxx.xxx:8080

GM

Hello, this usually comes from a misconfiguration in the public URL you define in Cells.

is the public URL (see defaults.url property of your ~/.config/pydio/cells/pydio.json config file) the exact same URL as the one that is served by your reverse proxy ?

hi bsinou,

the ip address are the same in json file and in apache configuration,

but the browser remains blocked with the error as in the previous image.
pydio and apache are in different machines and communicate only on the public network.

how can you solve it? thanks