No login after installation


Tried to install Cells 1.5.3 and 1.6.0 on Centos 7. Install was fine without errors, but after starting all I get is a grey screen that says “loading”.
I have no reverse proxy, no SSL configured yet.

Log shows…

2019-06-24T14:19:51.407+0200 ERROR Ladon blocked POST request at /frontend/session. Ladon Response: DefaultDeny:true

There are also some errors in the log about foreign key contraints

ERROR pydio.grpc.policy cannot insert relation between group oidc-actions-policies and policy all-users-login {“error”: “Error 1452: Cannot add or update a child row: a foreign key constraint fails (cells.idm_policy_rel, CONSTRAINT idm_policy_f2 FOREIGN KEY (policy_id) REFERENCES ladon_policy (id))”}

Hello @msommer,

Could you give me the following specs:

  • database version.
  • hardware RAM & CPU of your machine.
  • And your settings for INTERNAL & EXTERNAL url.

Also I would like to know if this was a first install or did you try multiple times?


DB is MariaDB 10.4
6 Cores, 8GB RAM
Internal and external url are the same (right now just the IP of the server, Port 8080)
I tried multiple times, but always dropped the DB in between.

For a complete clean/fresh install you must those 2 steps:

  • make sure to clean the database (just drop the db, as you did)
  • remove the Pydio Cells installation folder located inside ~/.config/pydio

Just do a remove command such as rm -rf ~/.config/pydio, then proceed to do a clean installation.

I did also delete all files you mentioned, but this did not help.

I now tried it with Mysql 5.6 instead of MariaDB 10.4 and with that it instantly worked.

Your manual states “MariaDB version 10.2 and above” as supported, this seems to be incorrect (at least for MariaDB 10.4).

our manual states this but we should have put a date on it or some sort of indication,
at that time we were referring to mariadb 10.3.

I will notify the devs that mariadb 10.4 is out (stable release, still not the official one) and we will take a look at it.