Newbie - cannot upload files greater than 10MB onto A2 hosting

upload
#1

Changed all the applicable php.ini settings upload, download and time on A2 hosting. Is there a seperate ini file for pydio

But I still cannot upload files greater than 10MB.

Any advice or ideas please.

#2

Hi,
you must also edit the /etc/php/7.x/apache2/php.ini file (otherwise it will override the values on the ui), and change the following values;

### Modify the values to allow bigger file uploads

Modify this file `/etc/php/7.2/apache2/php.ini`, and change the following values:

* **output_buffering**: to off, `output_buffering = Off`
* **upload_max_filesize**: to for instance `upload_max_filesize = 5G`
* **post_max_size**: for instance `post_max_size = 6G`
* **memory_limit**: for instance `memory_limit = 7G`

With the configuration above you can upload a file with a size up to 5G maximum

If you want to upload bigger files change the values above but by following this rule, **`post_max_size` must be bigger than `upload_max_filesize`**
#3

Unfortunetly I am not on apache server, as pydio was installed via Softaculous onto A2 hosting server.

#4

do you know which webserver is your pydio running on?

#5

The webserver is at a2hosting.com

#6

I think that you should reach to them and ask if it is possible to modify some php values,
or can you ssh into the server?

Ask them if you can modify the php.ini file and look at the values that i quoted before.

#7

I have have got A2hosting to update the settings, as follows. But still no upload greater than 10Mb.

upload_max_filesize 1G
post_max_size 1G
memory_limit 2G
output_buffering off

Any other advice. Surely I cannot be on my own with problems.

#8

Hi,

Try to config php.ini in .htaccess in the root of pydio folder.
Then verify the value by an phpinfo() to make sure

#9

If anybody can check the following out I would be gratefull of any advice.

.htaccess file as follows

<IfModule mod_rewrite.c>
# You must set the correct values here if you want
# to enable webDAV sharing. The values assume that your 
# Pydio installation is at http://yourdomain/
# and that you want the webDAV shares to be accessible via 
# http://yourdomain/shares/repository_id/
RewriteEngine on
RewriteBase /pydio
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php [L]

#Following lines seem to be necessary if PHP is working
#with apache as CGI or FCGI. Just remove the #
#See http://doc.tiki.org/WebDAV#Note_about_Apache_with_PHP_as_fcgi_or_cgi

#RewriteCond %{HTTP:Authorization} ^(.*)
#RewriteRule ^(.*) - [E=HTTP_AUTHORIZATION:%1]

#Following lines may be necessary for a PHP-FPM setup
# to make sure that authorization is transmitted.
# Just remove the # at the beginning of the line

#SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

</IfModule>

AddType application/json .json

As far as I can tell there is no specific php.ini but the general A2hosting v7 php setup is as follows.

|allow_url_fopen |On|
|allow_url_include |Off|
|date.timezone |America/New_York|
|disable_functions |no value|
|display_errors |Off|
|error_log |/home/gb/error_log|
|error_reporting |E_ALL|
|expose_php |On|
|file_uploads |On|
|include_path |.:/opt/alt/php70/usr/share/pear|
|log_errors |On|
|mail.force_extra_parameters |no value|
|max_execution_time |3600|
|max_file_uploads |20|
|max_input_time |-1|
|max_input_vars |10000|
|memory_limit |2G|
|open_basedir |no value|
|output_buffering |off|
|post_max_size |1G|
|session.gc_maxlifetime |1440|
|session.save_path |/tmp|
|short_open_tag |On|
|upload_max_filesize |1G|
|upload_tmp_dir |no value|
|zlib.output_compression |Off|