Missing Cells from home page


#41

hi guys, jumping in on that one.
Can you kindly summarize a reproducible scenario of what’s wrong? Hard to understand the whole thread from start :wink:
Thx
Charles


#42

First issue was that there was a limit of 50 on how many cells I could have. Creating a new one made old ones disappear from view. They still existed, I just could not see or edit them. Update 1.24 fixed this, but broke my shared users. Shared users as in the ones you can create from the cell creation window. They show up in settings as "shared" users. Now when I click on a user from people in the settings screen I get a blank white pop up where I should see the users profile.

Update 1.25 then made it where I can no longer edit any cell permissions. All cell permissions appear blank. And any attempt to make a change results in timeout exceeded or internal server error. I rolled back to 1.24.


#43

@zayn can you reproduce that? probably wth a lot of Cells…


#44

Hi,
sorry for the wait,
so basically i reproduced your case by creating hundreds of cells with shared users,
i could edit cells and i could edit the user (there was a slight bug, when you have lots of shared users you will have pagination hiding your internal users, which is going to be patched) nonetheless,
i would like to get more details on your setup if possible,
if you changed options, changed rights and so on.

I will try to reproduce your case in a more exact setup and see where the errors appears.

tldr; i did not get the errors but would like to get more details on your setup to test a bit more


#45

What else would you like to know? I have the admin user I initially created, he has about 60 Cells under that account. There are 3 internal users that are under a group/folder. As I create each Cell, I create a shared user for the Cell and give it modify access. I also give the mentioned group modify access.

Before patch 1.24 when cell 51 was created, some other cell would drop off the screen. This Cell was still visible to the user who I granted access. Patch 1.24 made it where i could see all my Cells again as the admin. But the 1st time a user needed a password reset, I went to the People settings screen and filtered by shared users. Opening any shared user results in a blank white popup screen instead of the user profile. Internal users are still ok.

Patch 1.25 was labeled “Hot Fix” so i thought i would give it a try. I can create a cell, but can’t add any permissions or edit permissions of existing cells, or even view permissions of existing cells. Any action to do so results in “Timeout 60000ms” or “Internal Server Error”.

I used a snapshot to go back to 1.24. If a user needs a password reset i have to delete the account and create a new one.


#46

Hi,
if i’m not mistaken it started at version 1.0?,
i tried many times this

  • installed a 1.2.3, created 100 cells with each a shared user (could not see my 100 cells, and had no access to settings)
  • upgraded to 1.2.4, i downloaded the 1.2.4 binary and did ./cells start (now i see all my cells, i can edit permissions, on the people menu i can edit and change the passwords for the shared users)
  • upgrade to 1.2.5 (using the gui), i still can see all my cells i can edit them, i also can see all my users and edit them.

It could be that my use case is not matching yours,
if you still remember how many users/cells you had on the previous versions i would like you to list them.


#47

i have tried to start from the beginning:

  • installed a cells 1.0.0 create 48 cells & shared users (i did not create 50 because it would block the settings)
  • checked if users, cells are editable
  • when it edition worked well, i upgraded to the next version until i reached 1.2.5

#48

Yes we started at 1.0.1. We didn’t notice the 50 cell limit right away. But I we had the issue before doing any updates, and kept applying updates hoping they would fix it until i finally opened this case. Do you know what the current version was on November 18? That’s the version we were on before upgrading to 1.2.4 to fix the initial issue. The only difference i see in your setup is that I have Cells running as a service. After each update the application will not work until the following commands are run.

service cells restart

setcap ‘cap_net_bind_service=+ep’ /home/pydio/cells

service cells restart


#49

Those commands are usual, they should not impact in any way.


#50

Here is a screenshot of trying to access a user profile. Would giving you a copy of the database or some log file help? Though i haven’t had much luck with the logs.


#51

Hi,
would you mind giving me a copy of your .config/pydio/cells and the database,
of course you have to remove all of the private data (it will also make the copy lighter), change all of the occurrences that shows your credentials,such as the database, server (ip, domain name) etc… change them to values like (example.com, examplePwd,…) and as for your users, i only need the admin password so just change it to something easy.

After that i should be able to use your files to start a 1.2.5 with all of your shared users/cells and see if the issue happens for me.


#52

i can zip up and copy the .config/pydio/cells folder. i used mysqldump to get a backup of the db, but i’m not sure how to alter the password or anything in there. I can’t change my admin password from the web interface either, it tells me ‘passwords don’t match’.
I made another admin user. Username:password. tempadmin:P@$$w0rd
There are over 50 users, this temp admin can only see about a dozen of them, and they all work fine. They were created after the update. The 50 or so users created before the update that are broken are not visible to the new admin. So maybe if you can see what the difference in the users is then we will find the problem. 1 broken user is named “advarra”

How can i upload the files?


#53

mmm,
i don’t have an idea for where you would be able to upload them.


#54

i uploaded them to the server in question here… https://files.imedris.net/

Username: pydio
Password: Pyd!o156


#55

Hi,
ok now i have exactly your setup (i changed the user admin password using the tempadmin),
i see the blank window when you try to edit the old shared users.
I’ll instigate it.
I know it seems repetitive but would you mind giving me a bullet point list of the all the issues that you encountered, since i have your setup it will be easier for me to confirm it.


#56

Sure.

  • Blank User profiles from Settings/People (only users pre-update)
  • Internal Server Error, or Timeout 60000ms when editing permissions on current cells
  • Can’t view “real” permissions on current cells. Shows with no permissions when there in fact are people with access. Every cell should have 2 users that have access, so if you see a blank one it has an issue.

#57

Hi,

for this one it should be fixed, could you take a look at the latest push on git,
you would need to build the binary yourself,
if you want to i could build it and share it for you if can create a cell for me.

I did not encounter those 2 errors, but it could be because i kinda re organized your roles (i’ll show you so that you can do the same).

Create a profile administrators with:

  • Role info > Apply automatically to profile admin.
  • Application Pages > Read & Write on admin console (settings)
  • then hit save

Then edit the root group (root group is the group that will be given automatically to all internal users)

  • Role fino > remove the applied auto profile,
  • Application Pages > Remove the read & write on Admin Console (settings)
  • Hit save

#58

I actually just saw it once, but i cannot reproduce it regularly, i’ll have to figure the trigger.


#59

If you can build it and put it in the same cell i shared the database and config files to you please.

So you are saying to create a new role named “Administrators”, and give it the permissions the root group role would have? and apply that role to my admin user and remove the root group role?


#60

more like, an administrator role that will only apply to administrators threfore giving them access to the settings,
and the root group is more a group used to set the default rights for all internal users (for instance giving them read and write access to the my-files, common-files and so on), for the shared users they have the external-users roles.