Docker-Compose - First install fail


I have a fresh Ubuntu installation with Docker and Docker Compose.

I have created a docker-compose file according to:

Have changed CELLS_EXTERNAL to “pydio:8080”.

The containers starts up.
But I get:

cells_1 | ****************************************************************************************
cells_1 | #server ells_1 | # ✗ Oops, cannot find a valid configuration for the database!
cells_1 | #
cells_1 | # A - If it is the first time you start cells, make sure to first run the install step:
cells_1 | # $> cells install
cells_1 | #
cells_1 | # B - If you have already installed, maybe the configuration file is not accessible.
cells_1 | # Make sure you are launching the process as the correct OS user.
cells_1 | # Currently running as ‘root’
cells_1 | #
cells_1 | ****************************************************************************************
cells_1 |
cells_1 | Exiting now…
pydio_cells_1 exited with code 0

I have firewall disabled. How do I run cells install? The user guide says I shall run the setup in the browser. I cannot reach http://pydio:8080/ on my local netowork (the DNS are ok here).

Please advice me!


make sure to clean the volume if you attempted to install multiple times,
you can use docker system prune -a and docker volume prune .

Thanks, I did the pruning of everything as explained. Then I could start it up again.
I get the message:

Installation Server is starting …
cells_1 | internal URL: http://localhost:8080
cells_1 | external URL: http://pydio:8080

When trying to browse the Pydio from another machine (http://pydio:8080) I just get:
404 Site pydio:8080 is not served on this interface
It seems like the Pydio container are answering at least a 404 page…

Thanks for your help!

Tried to set internal URL to Then I could reach it by the external URL pydio:8080.

Installing… :slight_smile:

One goal I have is to https-idize my SMB fileserver shares. It shall be possible with Pydio.
I have read here:

Do I understand it correct: I have to mount the SMB share in the host environemnt. How do I expose it to the container? Or is it another way?..