Large file (> 4GB) display size is wrong… (again, sorry !)


#1

using the standard fileSystem driver, the size of files above 2GB need Real_size_probing even on a 64 bits sytem ; then they are reported correctly up to 4GiB. Size of files 4GiB or above are reported incorrectly: they are truncated of 4GB.

2GiB.dd :
dd if=/dev/zero of=1GiB.dd bs=1048576 count=$((2*1024))

2GiB-plus1MiB.dd : (2049MiB)
dd if=/dev/zero of=2GB-plus1MB.dd bs=1048576 count=$((2*1024+1))

3GiB.dd :
dd if=/dev/zero of=3GiB.dd bs=1048576 count=$((3*1024))

4GiB-minus1MiB.dd :
dd if=/dev/zero of=4GiB-minus1MiB.dd bs=1048576 count=$((4*1024-1))

4GiB.dd :
dd if=/dev/zero of=4GiB.dd bs=1048576 count=$((4*1024))

4GiB-plus1MiB.dd : (4049MiB)
dd if=/dev/zero of=4GiB-plus1MiB.dd bs=1048576 count=$((4*1024+1))

is this something that could be fixed?

thanks

System info :
Linux m 2.6.32-39-pve #1 SMP Fri May 8 11:27:35 CEST 2015 i686
PHP Version 5.6.33-0+deb8u1
Pydio : 8.0.2 (upgraded from 8.0.1 to try to work around this issue)


#2

Hi,
did you modify something about sizes in your php.ini file ?


#3

not sure how these settings would interfere with the bug, but here you go:
m:~# cat /etc/php5/apache2/php.ini | grep -i size | grep -v '^;'
post_max_size = 200M
upload_max_filesize = 200M
pdo_mysql.cache_size = 2000
mysql.cache_size = 2000
mysqli.cache_size = 2000


#4

Hi,
i asked because if your upload size file is not well set it might be why you cannot get a complete file and that might be why it’s messing sizes up.


#5

the files are the expected size :wink:
ls -l *.dd
-rw-r----- 1 axolotl axolotl 2147483648 Feb 19 11:06 1GiB.dd
-rw-r----- 1 axolotl axolotl 2148532224 Feb 19 11:06 2GB-plus1MB.dd
-rw-r----- 1 axolotl axolotl 3221225472 Feb 19 11:07 3GiB.dd
-rw-r----- 1 axolotl axolotl 4294967296 Feb 19 11:06 4GiB.dd
-rw-r----- 1 axolotl axolotl 4293918720 Feb 19 11:08 4GiB-minus1MiB.dd
-rw-r----- 1 axolotl axolotl 4296015872 Feb 19 11:06 4GiB-plus1MiB.dd


#6

Hi,
yes i reproduced your case as seen in those screens
and yes i have your issue i’m going to ask the devs about it.


#7

Hi,
sorry for the delay, could you try updating your php version ?
when you enabled the real size probing it should work, another way of testing one more time on your end would be to create a new workspace and assign it to another folder.
as you can see in my screenshot i dont have the issue


#8

Hello

PHP version is already the last available PHP 5 version on Debian stable!
Upgrading to PHP7 is not an option here

regards,

Michael


#9

also I already tried changing workspaces, i lost quite a few hours on this issue already :wink:


#10

yeah, now that i reproduced and had no issue it’s harder to find it ^^ .

here i had the issue

and here it disappeared

edit : and of course in between the only thing that changed was on the 1st try i was on ubuntu and the 2nd i was on debian.


#11

Hello
I’ve the same issue, with the 8.0.2 community edition, installed on Debian 9.
Just to compare, i’ve tested the pydio 8.0.2 enterprise edition (Appliance) and it is good on this one.

What’s wrong with the community edition ?
It is a bug or a limitation implemented ?
I’ve modifiied values for post_max_filesize and upload_max_filesize.
No ways !

Regarding running configuration i can see new values configured via the php.ini.
Unfortunatlely i can’t uplaod files :o/

Any workaroud please ?

My configuration is as follows

Client : Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 1G
Memory Limit : 128M
Max execution time : 30
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /var/lib/php/sessions
Session Save Path Writeable : Yes
PHP Version : 7.0.27-0+deb9u1
Locale : C
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 1073741824
PHP Post Max Size : 1073741824
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes

What’s wrong ?

thanks

Regards

Mc