Pydio cells installation


#1

Hi there. I was tryng to install pydio cells on Ubuntu 18.04.2 Server (in Hyper-V) using this guide

instead of downloading the 1.0.1 version (as linked in the guide) I have downloaded the 1.4.0
The problem occurs at the moment in which I run the command “./cells install” because I get this:

panic: runtime error: invalid memory address or nil point dereference

I was thinking that it could occur because the apache2 service is running (in the beginning it’s specified that this service has to stop) but it installed itself at the moment I installed php and I’m not able to stop it. Maybe this is the problem?

Regards,
Gabriele


#2

Hi,
you could disable apache, but it should not be an issue if you are binding cells to a port different than 80 or 443.


#3

@zayn couldn’t this be linked to the need of having an private IP ?


#4

Thank you. So what do you think I could do to try to solve this problem?


#5

sorry charles, I didn’t read your answer. The Ubuntu server got an IP from DHCP. We need tu run Pydio Cells on a local network, I suppose this could change something


#6

As Charles pointed it out, do you have a private interface on your server.
usually you should have one.


#7


This is the entire stack if you need.


#8

Could you show me the output of your ifconfig,
you can hide the sensitive addresses.


#9

Here it is


#10

Could you describe what you put on the settings when you install,
more importantly what you put for the internal & external urls.


#11

I followed the guide above. I installed a clean Ubuntu Server 18.04.2 then installed and configured mysql and PHP. No changes to the network or other. When I go to install cells I get that error. In the meanwhile I will try to repeat the installation on a physical machine and not in a virtual environment


#12

It should not be an issue that you are on a physical machine or virtual env.
By the way php is no more required.
Do not hesitate to ask me if you are still stuck.


#13

Ok, I will try a new installation whthout php. Let’s see what happen


#14

nothing, reinstalled ubuntu + mysql and at the moment of installing cells the same error as above. Maybe wrong permissions to the install file?
I run on it :
sudo chmod u+x cells
sudo chown pydio.pydio cells


#15

Hi,
are you running ./cell install as the pydio user ?


#16

during install I made only one user named pydio


#17

Hi @assitec

I don’t know why but Pydio Cells needs one IP address in private range, and 192.0.x.x is not private range.
You need to fake one network with a private ip range:

10.0.0.0 - 10.255.255.255 (10/8 prefix)
172.16.0.0 - 172.31.255.255 (172.16/12 prefix)
192.168.0.0 - 192.168.255.255 (192.168/16 prefix)


Regards, Hrvoje


#18

Hi @charles

I still don’t get why Pydio Cells needs a private IP to make it work?
Is 127.0.0.1 not private enough?
Why force the use of 10.0.0.0, 172.16.0.0, 192.168.0.0 ?
Why would you limit it like that?
Not every server on the internet is behind some proprietary Firewall/NAT solution, a lot of them are directly on the internet, and the explanation in troubleshooting is realy stupid: “This typically happens on small VPS that are hosted in the cloud and don’t have a private address by default.”

Regards, Hrvoje


#19

Zayn, checking the version I realized that 1.4.0 was released yesterday. I dowloaded the 1.2.5 and the install started. Do I need to install PHP for this version?


#20

thanks for your tip Hrevoje, I suppose have to reach that situation yet. I’m trying to install now. How do I have to configure the host parameters to have pydio working in a local network?