Docker install wont works


#1

Hello!!

I’m trying use Pydio Docker, with the basic syntax and it’s not working.

$ sudo docker run -it -p 8080:8080 --name test pydio/cells:latest

I get this output from containter:

cells_1 | 2019-01-11T18:31:37.767Z INFO pydio.rest.install Starting installation now {“bindUrl”: “”}
cells_1 | 2019-01-11T18:31:39.865Z INFO pydio.rest.install stopping
cells_1 | 2019-01-11T18:31:39.865Z INFO http: Server closed
cells_1 | 2019-01-11T18:32:09.865Z INFO [ERROR] Stopping :8080: context deadline exceeded
cells_1 |
cells_1 | :heavy_check_mark: Installation Finished: server will restart
cells_1 |
cells_1 | 2019-01-11T18:32:09.869Z INFO pydio.grpc.data.objects started
cells_1 | 2019-01-11T18:32:09.880Z INFO pydio.grpc.data.objects Starting umbrella service pydio.grpc.data.objects. with sources {“sources”: [“local1”]}
cells_1 | 2019-01-11T18:32:09.888Z INFO pydio.grpc.update started
cells_1 | 2019-01-11T18:32:09.891Z INFO pydio.grpc.data.sync started
cells_1 | 2019-01-11T18:32:09.892Z INFO pydio.grpc.data.sync Starting umbrella service pydio.grpc.data.sync. with sources {“sources”: [“pydiods1”, “personal”, “cellsdata”]}
cells_1 | 2019-01-11T18:32:09.935Z INFO pydio.grpc.jobs started
cells_1 | 2019-01-11T18:32:09.971Z INFO pydio.grpc.log started
cells_1 | 2019-01-11T18:32:09.971Z INFO pydio.grpc.chat started
cells_1 | 2019-01-11T18:32:09.962Z ERROR pydio.grpc.meta Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.972Z INFO pydio.grpc.config started
cells_1 | 2019-01-11T18:32:09.962Z ERROR pydio.grpc.changes Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.973Z ERROR pydio.grpc.user-meta Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.974Z ERROR pydio.grpc.auth Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.974Z ERROR pydio.grpc.data-key Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.980Z ERROR pydio.grpc.workspace Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.985Z ERROR pydio.grpc.user-key Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:09.994Z ERROR pydio.grpc.acl Could not prepare start {“error”: “Storage is not available”}
cells_1 | 2019-01-11T18:32:10.028Z INFO pydio.grpc.docstore started

Tks


#2

Hi,
first let’s make sure that you do not have another app using the 8080 port then, tell me which database did you use (version for instance maria db10.3, etc…), and also could you tell me how you try to access the cells inside the container, (localhost:8080, or ip:8080)


#3

Hi @zayn
I have only this app running on 8080. I’m using Percona XtraDB Cluster 5.7.23.
I access the container using the browser at http://localhost:8080/

Do you see that “bindUrl”: “”} is empty ?

Thank you.


#4

Hi,
yes by default the bind & external are set to localhost:8080, after you ran the command, to access the install you must go to https://localhost:8080, (by default ssl is enabled you must set the env to 1 if you do not want to).

You can change them with the following env:

  • CELLS_BIND=localhost:8080
  • CELLS_EXTERNAL=localhost:8080
  • CELLS_NO_SSL=0

those are the env by default that you might need to change according to your setup, usually you can for instance put the ip of the host machine running the container.

Now onto the issue, i do not have knowledge of percona but it could be a db issue, i’ll do some testing while you try with new env variables.


#5

i’ve just tested percona:latest and it works so it could be a configuration issue, let’s work this,
you might have to try with the env variables for instance:

docker run -d -p 8080:8080 -e EXTERNAL_BIND=192.168.1.1:8080 -e CELLS_BIND=192.168.1.1:8080 -e CELLS_NO_SSL=1 --name cells pydio/cells:latest

then access with http://192.168.1.1:8080
(change all the address occurences with the one of the machine running the container)


#6

Hi !
I can not put my output where cause “Sorry, new users can only put 2 links in a post.”


#7

you can send them to me if you wish to avoid removing every single link.


#8

Hi !!

Still not working…

fyi, I’m using an external database server, then I replace ‘localhost’ by my database server ip address and user at install menu… but I not see it at log:

tks

$ sudo docker run -it -p 8080:8080 -e EXTERNAL_BIND=10.80.14.14:8080 -e CELLS_BIND=10.80.14.14:8080 -e CELLS_NO_SSL=1 --name cells pydio/cells:latest

[Configs] Upgrading: setting default config services/pydio.grpc.auth/dex/issuer to /auth/dex
[Configs] successfully saved config after upgrade - Reloading from source

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data

  • IPs and ports for binding the webserver to outside world
  • MySQL 5.6+ (or MariaDB equivalent) server access
    Pick your installation mode when you are ready.

Cannot find vaultKeyPath, creating new one /root/.config/pydio/cells/cells-vault-key


#9

Hi,
could you describe me when it fails, with the logs showing the failure,
and by the way:

is this address pingable from the outside?

here’s a screenshot of when you put the database infos on the web install,


#10

Hi.

How you can see in pictures, the information about the database in webinstall does not match the information that is in the browser.

This ip address is from my internal network, not available at internet.

I’ll be gone for the next two weeks.

Thank you.


#11


#12


#13

it could be that docker could not reach this address,
is it the only network adapter on the machine running docker?

Could you do a ifconfig, and show me what you’ve got.


#14

Try setting it up this way:

(Run once) docker network create my-network
docker run --rm -d -v z:\docker\mysql:/var/lib/mysql --name mysql-server --network my-network -e MYSQL_ROOT_PASSWORD=secret mysql:5.7
docker run -d -e PYDIO_LOGS_LEVEL=production -e CELLS_EXTERNAL=localhost:8080 -e CELLS_BIND=localhost:8080 -v z:\docker\pydio:/root/.config/pydio/ --name pydio --rm --network my-network -d -p 8080:8080 pydio/cells

Then get the IP of the mysql-server container
docker inspect mysql-server

eg “IPAddress”: “172.18.0.2”

Then use this IP when configuring the mysql DB.