Collabora Online - Docker partilialy working - cells 2.2.2

Dear Pydio Team,

I have read a lot regarding Collabora Online Docker install and configuration but I am still facing an issue and will try to explain it so detailed as possible. It is working partitialy but not for my use case.

How I use Pydio Cells:
DynDNS set at my Internet Router → https port-forwarding to cells server

Pydio Cells and Cells Sync is working properly with DynDNS Domain & TLS.

How I tested Collabora Online working properly:

  1. changed/added cells with command ./cells configure sites to listen to localhosts IP
  2. opened firewall port 9980
  3. docker run -t -d -p 9980:9980 -e “extra_params=-o:tls.enable=true” -e “domain=<localhost_IP>” collabora/code
  4. open cells via browser with localhost IP and enabled Collabora Online plugin
  5. opening Office documents works fine with this configuration

What I tried after to configure Collabora Online to work for my use case (not working):

  1. changed/added cells with command ./cells configure sites to listen to DynDNS
    image

  2. Set additional 9980 port-forwarding at my Internet Router to cells server

  3. docker run -t -d -p 9980:9980 -e “extra_params=-o:tls.enable=true” -e “domain=<DynDNS_Domain>” collabora/code

  4. open cells via browser with DynDNS Office documents opens with blanc page

  5. open cells via browser with localhost IP Office documents opens correctly (even DynDNS is set to docker run command [strange!])

Are you able to help me to get Collabora Online working in combination with my use case?

Realy appreciated if we get it to work.

Thanks in advance and best Regards,
Denx

Dear Pydio Team,

Is there a reason why it was not replied after 11 days?
May the issue nothing for this forum to be answered?

Thanks and best Regards,
Denx

hi @denx
sorry, no answer because no-body could find the time to retest the whole setup… be patient :slight_smile:
-c

Hi,

Just to make sure, don’t run the two collabora docker (the one with ip and the one with dns domain) at the same time because your port binding will be clashing.

Did you escape your dns domain properly in the docker setting ? It’s the only thing I can think of first hand. Can you have a look in the collabora docker logs when opening a file with a blank page to see if there is any meaningful error ?

Thanks,
Greg