Clean Install Fails

install
#1

I’m doing a browser based install onto a fully patched debian 9 system with MariaDB 10.3.14.
The install command runs ok through the initial config and everything goes through on the web until it gets to ‘apply installation\creation of logs directory’. On the next step it throws and error
Request has been terminated Possible causes: the network is offline, Origin is not allowed by Access-Control-Allow-Origin, the page is being unloaded
Watching the install run in the console, there is an error but it flashes by so quick, I cant see what it is.
If I try access the site, all I get is the loading logo and nothing else.

Can anyone point me to where the install dumps its logs so I can try work out what’s failing or is there some way of slowing the console output so I can see what error it’s throwing?

#2

Hi,
what pydio cells version are you installing (if you don’t know you can do ./cells version
could you describe your setup (os, software versions) do you have a reverse proxy and also what did you put during the install.

#3

Hi Zayn,
We are running Pydio Enterprise 1.5.0
Debian 9.9
MariaDB 10.3.14
We don’t have a reverse proxy running

During the install we logged in with a dedicated user account & used the following settings
Browser-based install
internal url=servername.domain.local:9000
We have a public key and cert for the external url so directed the app to those files
redirect 80 to https - yes
external url=https://cloud.domain.com

At this point we go to another system and point the browser to the internal url as the debian 9 system is console only
enter the enterprise license
configure the database
configure the site name and admin details
edit the path of the default data source (we have a big network drive mounted)
click on the install now

On the web interface we get an error almost immediate but looking at the console i’m seeing cannot run action ‘action.command.resync’ and a lot of pydio.gateway.proxy restarts

Anything else you need, let me know

#4

Just to be sure you used setcap 'cap_net_bind_service=+ep' cells-enterprise (to enable port 80 & 443 access), also could you show me some lines from the cells.log.

#5

This may be me being stupid but I can’t see cells.log.
I’ve got audit, caddy_errors & tasks logs under .config/pydio/cells/logs/, nothing else.

#6

oh my bad, to have cells.log you must use it as a service (systemd, supervisord) could just show me what you got on the terminal.

#7

Hello.

I don’t really understand your setup: you say you are not running behind a reverse proxy and yet says that you defined a bind URL with a custom :9000. That cannot work.

If:

  • your Pydio Cells instance is directly facing internet
  • you rely on the embedded Caddy to be the TLS termination point for your FQDN

you must use the :443 port for your Bind URL.

About where to find the logs, as @zayn said, it depends on how you start the app:

If you have done a ./cells-enterprise install with a remote ssh client on your server, the full log is in the console. Same if you then do a ./cells-enterprise start

Then if you start Cells with systemd or supervisor, you define where to find the logs in the configuration files of these tools, as explained in the doc here for instance.

Thus said, if you still have a problem installing, we will need the install log from your console to help further.

Regards.