Cells: Error 1062: Duplicate entry '1' for key 'PRIMARY'"


#1

Hi Community,
after a new installation I have this formation in the LOG: Duplicate entry ‘1’ for key ‘PRIMARY’"
How can I turn that off?

2018-07-30%2017_50_08-MQS%20Data%20Exchange%20-%20Settings

Server: Ubuntu Server 18.04
Pydio: Pydio Cells Home Edition 1.0.2
Pydio deployment type: archive
Underlying stack information: apache (not active) / PHP 7.2.7 / MySQL 5.7.22


#2

Hi,
does it cause any kind of problem with your day-to-day utilization of cells?
and if so could you tell me where/what and when this error occurs.


#3

Hi zayn,
this error comes up every 10 minutes (please look at the picture).
The problem occurred immediately after reinstallation and has persisted until now. It doesn’t seem too bad, but it’s insulting.


#4

Hi,
when you reinstalled did you use a new database?, to put it simply what did renew?


#5

Hi zayn,
yes, I used a fresh database. The error was always there right after the first login to a freshly installed database. I have already reinstalled several times.


#6

Hi,
what i suggest would be to reinstall but this time could you also remove the old cells files,
they are located in ~/.config/pydio just do an rm -rf ~/.config/pydio and i think it should be ok after that.
The error seems to point that there’s a duplicate of a key, could’ve happen when you tried multiple installs.


#7

Hi zayn,
I forgot to mention: I did that, too. I created a new database and deleted the cells home directory before reinstalling.


#8

Oh, do you mean if I run .cells /install multiple times?


#9

The problem was that I often could not log in with the admin user entered during installation. Then I started the installation several times (maybe without deleting the home directory).
Can that be the reason? But then I don’t dare to reinstall it. Because I had the problem with the admin login after the first installation again and again.


#10

It could be, but if you couldn’t log with your admin user then your password must be the issue,
if it’s too private could you tell me if you have special chars in your password,
and in that case could try to install cells with login : admin password : admin to be sure, but yeah if you ran multiple times ./cells install it could be why there’s a duplicate of key.


#11

Hello, zayn,
yes, I have a"!" and a"?" in my password. And because it no longer worked with “admin”, I now use the “pydio_admin”. But “admin” also worked in my first installation. Only after that, I wasn’t so lucky with the username. However, the password was always the same. Right now I don’t want to reinstall. The system is in use. I’m trying to find a good time.


#12

i think that it’s fixable by just deleting the entry i will ask the devs where can i find it, so that you don’t have to reinstall.


#13

Hi zany,
that sounds good. That would be my favorite solution :slight_smile: