Cells Client Oauth 404

I’m trying to log in to the cells server using the oauth method cec config add oauth, but when the URL opens in the browser the page shows 404 not found. I’ve also tried bypassing our nginx proxy on 8080 and I still get the same response. Does anyone have any ideas,

Thanks
Josh

What version of the Cells server and client are you using?

Have you double checked the URL that is used by the client to open the OAuth2 page, it is displayed in the command line when you launch the process:

user@vox:~$ cec config add oauth
Server Address (provide a valid URL): https://files.example.com
✔ No
✔ Yes
Opening URL https://files.example.com/oidc/oauth2/auth?client_id=cells-client&redirect_uri=http%3A%2F%2Flocalhost%3A3000%2Fservers%2Fcallback&response_type=code&scope=openid+email+profile+pydio+offline&state=GVdVdMfuUNCjFHWY

If you try to curl the beginning of the url from your client machine, do you also have a 404 ?

user@vox:~$ curl https://files.example.com/
<a href="/login">Found</a>.

user@vox:~$ curl https://files.example.com/oidc/oauth2/auth
<a href="https://files.example.com/oauth2/fallbacks/error?error=invalid_client&amp;error_description=Client+authentication+failed+%28e.g.%2C+unknown+client%2C+no+client+authentication+included%2C+or+unsupported+authentication+method%29&amp;error_hint=The+requested+OAuth+2.0+Client+does+not+exist.">Found</a>.

(PS: I have been replaced my URLs by files.example.com before posting)