Cannot Generate OAuth2 Token - "redirect_uri" parameter does not match

Morning!

In Short
I’ve been attempting to generate a token for some API work by following the official docs and forum posts, but I keep hitting this redirect_uri error brick wall.

Environment
I have an Unraid Server and have installed the Pydio Cells 2.1 Home docker container on https://192.168.1.100:8080. The web frontend works without issue.

Method
I’m focusing on following the Postman config example, and currently have the following parameters:

Problem
Whether I use a Callback setting of

I always get the redirect_uri error message:

The request is missing a required parameter, includes an invalid parameter value, includes a parameter more than once, or is otherwise malformed" error=invalid_request hint="The “redirect_uri” parameter does not match any of the OAuth 2.0 Client’s pre-registered redirect urls

The only other clue I found was using the openid info page https://192.168.1.100:8080/oidc/.well-known/openid-configuration which seems to confirm that I’m using the right settings?

Help?
I’ve read through what I think are the pertinent docs and forum posts. The closest matching post seems to be this one, but the advice of ‘restart cells’ doesn’t work, and there hasn’t been any other follow up.

Any advice on what I should change or try next?

Finally figured it out!

First, I noticed that I was using the wrong callback url, so I changed it to http://localhost:3000/servers/callback. This still didn’t get me around the issue.

Someone suggested that I needed to put something into the State box. This sounded familiar so I looked into the official documentation and found:
State: you can put whatever you want (minimum 8 characters)

I had read this statement as “you can leave this blank OR put a minimum of 8 characters in this box”, and had left the box empty up until now. As soon as I typed in 8+ chars, bingo!

Hello @zolointo,

Glad that you figured out your issue,

We will change the wording on the documentation so that it suggests that you “must” put a state with the 8 characters condition.