Can´t write to tmp directory (411)


#1

Fresh Install / Pydio 8.0.2 / Pydio Community (.zip), / Apache 2.4.26 / PHP 7.1.7 / MySQL 5.6

Dear Pydio Community,

iIcan´t upload larger files (tested with 30MB, but would guess > 10MB). Small files will be uploaded (few MB).

The Error: Unexpected response: Error while Uploading: No write access on folder for temporary files (411) <-- this is translated.

What I tried:

  1. changed tmp-directory in Pydio core settings via Browser (permission of folder always set to 777)
  2. changed tmp-directory in bootstrap_conf.php
  3. changed tmp-directory in php.ini
  4. changed tmp-upload-directory in php.ini
  5. changed upload_limit and several other variables to higher values in php.ini
  6. checked if php-command line is enabled, as pydio tries to to background operations while processing large files
  7. checked run_tests.php, but just ssl-encription-warning

Also looked at php.log, but no entry whatsoever. Does Pydio has a detailed log-file, that I could analyze? Just found the log in the browser interface, but this doesn’t do much.

I am out of ideas, so I made this account to ask the community. Any advice?
Sincerly, Tobi


#2

Hi,
your issue is weird, for pydio logs you can check them in the database base under the table ajxp_log.


#3

Hi what’s your OS ? Did you try to chown your tmp folder to www-data or equivalent instead of chmod-ing to 777?


#4

Hi Charles,

my OS is Windows 10 Pro x64. I chown-ed the whole Pydio-Folder to the according user. (There are different FTP and SQL-User for different domains/filespaces).

Also I got some good?! news:
Seems like a major problem was, that I was using PHP 7.1.7 while some php-modules still were at PHP 5.6 or at least php tried to work with the old ones. After going back to php.5.6 I could upload files again. I tried with a 97MB-File so far, 200MB failed with the 411 Error again.

Interessting thing: I just found out about this, because deleting of big files didnt work either, but this time there were entries in the php.log about like 30 php-modules that were unable to initialize.

I want to upload files up to 1 GB, that s the current goal. What need I do to achieve this?

Sidenote:When I try to upload files, the progress bar just runs straight to the end and stays there, until the upload is completed. I have no info on the progress whatsoever…is this normal?


#5

I’m getting the same issue on linux

The HTTP Status Code 411 (Length Required) means that the server is refusing the file because it was sent without a content length header.


#6

Hi,
could you open a new post with your Pydio version, php version, OS and mysql version just to have all the base covered and i you can add your php/apache logs with the error it would be wonderfull, here’s a trick to get logs on the web ui of your pydio

DEBUG MODE PYDIO

Go to conf/bootstrap_context.php .
Switch this line to true : 
define("AJXP_SERVER_DEBUG" , true);