API v2 POST resulting in "Cross Repository copy is not implemented"

Quick Description
I’m trying to use Python’s requests library to execute a PUSH in combination with /api/v2/fs/ to move a file from api-testing to api-testing/Archive. This is generating the response “Cross Repository copy is not implemented”

I’ve been given API access on a Pydio server that has two repositories (I think that’s the right convention?):

Where each URL takes me to a separate login screen, and my login will not work on the first, but will work in /myarea.

I have been able to create the code that I need to explore all of my workspaces, list out all of the files and folders, and upload new files to the server.

Current Issue
Moving existing files is just not happening, no matter how I format my url.

thisserver. com/myarea/api-testing is my testing workspace
thisserver. com/myarea/api-testing/xyz.txt is my test file
thisserver. com/myarea/api-testing/Archive is where I want to move the file to

If I run a GET on
thiserver. com/myarea/api/v2/fs/api-testing/Archive/xyz.txt
I get all the details about that file.

If I run a POST on:
thisserver. com/myarea/api/v2/fs/api-testing/Archive/xyz.txt?copy_source=api-testing%2Fxyz.txt&delete_source=true&override=true&recursive=true"
or (extra bracket in front of api-testing on the copy_source):
thisserver. com/myarea/api/v2/fs/api-testing/Archive/xyz.txt?copy_source=%2Fapi-testing%2Fxyz.txt&delete_source=true&override=true&recursive=true"
or (removing destination file name)
thisserver. com/myarea/api/v2/fs/api-testing/Archive/?copy_source=%2Fapi-testing%2Fxyz.txt&delete_source=true&override=true&recursive=true"

I get this response:

<?xml version="1.0" encoding="UTF-8"?>Cross Repository copy is not implemented on this api.

What am I doing wrong? I know it must be something to do with myarea being a sub-repository of the main site, but I have no idea what to tweak in the POST url to make it go.

Please help!

Resolved it by supplying the copy_source argument the actual repository id instead of the slug
?copy_source=api-testing%2Fxyz.txt does not work
?copy_source=c60705de61b431048d1411b3a03c360d%2Fxyz.txt works