Upgraded to v3, "Unsuccessful HTTP Response"

Hello all,

So I just upgraded from 2.2 to 3.0.3 using the in-app software upgrade, and it appears as though all my workspaces are broken now! All that I get is “Unsuccessful HTTP Response” when I access Pydio (very informative) and taking a glance at the debug info in-browser, it appears that trying to access the workspaces and their files fires a slew of 500 errors. This only occurred after updating to v3.

I ensured that the setcap had been performed on the new binary, but despite some restart attempts I’m still having no luck getting things to work.

Taking a closer look at the requests, they all appear to stem from the /a/ directory (including but not limited to: “/a/jobs/user”, “/a/activity/stream”, “/a/meta/bulk/get”), all returning 500 errors.

Furthermore, when starting Cells (cells start) I see an error stating that pydio.grpc.jobs could not run (“error”: “timeout”)

Any idea where I might begin to try and fix this…?


Hello @Marc_Seamus,

Could you tell me how you manage cells, do you start the binary with systemd or with a script ?

Furthermore, are you running Cells with the same user on your server ?

This shows that the api did not start (the API endpoints are /a/service/...).

Also, do you have the logs when you updated and after the update ?

Hello Zayn,

I am running Cells in Nginx via reverse proxy and it is started and stopped by a service in systemd. Cells is being run by a “pydio” user.

I took a look at it again with a fresh mind and did some experimenting. Upon shutting down the service, I ran the cells start command and found that everything worked as expected. (As opposed to erroring out during startup, which makes sense since there was already an instance of cells running.) However, after exiting out of it and running systemctl start cells, everything appears to be working fine again. For reference, yesterday I had tried a systemctl restart cells several times to no avail. Strange!

I suspect there were two instances of cells attempting to run at the same time, as I noticed that after shutting down the cells service, cells was still running in the process list (many instances of it in fact). I am wondering if shutting down the service, then running it manually via command cleaned up the processes?

Either way, it seems to be fixed. If anyone else stumbles across this issue following an upgrade, hopefully this will provide them with something to try.


This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.