Upgrade from 8.0.2 to 8.2.0 fails w/writeable error

php5x

#1

I have read through all of the related posts (i.e. here and here) for previous versions/upgrades and none seem to apply or provide a solution though the issues/error messages are identical.

I am running Pydio on a QNAP TS-453A. It installed and runs perfectly, but when I try to update from 8.0.2 to 8.2.0 via the updater in the gui I get the following information:

Applying upgrade pydio-core-upgrade-8.0.2-8.2.0.zip
Checking download permissions
- OK
Downloading upgrade archive
- File saved in /share/CACHEDEV1_DATA/.qpkg/QPydio/QPydio/data/tmp/update/pydio-core-upgrade-8.0.2-8.2.0.zip
Checking archive integrity
- Hash is ok (cdb26dc061c5c54761374cb8d14ab12b)
Checking files and folders permissions, this may take a while.
- Error : Crawling folder to check all files are writeable : File FAIL! Please make sure that the whole tree is currently writeable by the webserver, or upgrade may probably fail at one point.

I have checked the database as recommended in some posts and have tried to determine what rw settings to change but can’t quite match up with the answers posted and the structure on the QNAP.

One post recommended that the “entire tree” needed to be writeable, but I have no idea what “entire tree” refers to on QNAP. Is it the Pydio install folder?

Any help would be appreciated.


#2

Hi,
this error is listed and has the solution right here.


#3

Hi,
sorry i actually didn’t put all the solution and i’ve just realized it ( silly me ),

To resume all ,you have to delete a file(sym link) named less that should be located in 2 locations :

location one : /pydio/plugins/gui.ajax/res/themes/common/css/mui
location two : /pydio/plugins/gui.ajax/res/mui/
it should work when you have removed it in both of those folders.

Thanks, I had read that post previously.

Problem with that “solution” is that neither of those locations contain a file simply named less.
Location one: has custom.less, pydio-mui.css, pydio-mui.less, and pydio-variables.less
Location two: is empty


#4

Hi,
it’s weird,
this file ( it’s a sym link ) is the one causing the troubles, because the upgrade process first checks if everything is writable etc… and since this less file is pointing to nothing it makes the error occur and prevents from upgrading.


#5

I hear ya, but I guess that is not the issue for me.

image
image


#6

Hi,
oh you’re on windows i don’t know if windows will display a sym link, you might have to check display hidden files.


#7

The NAS itself is Linux and I can access the same folders there, just prefer the Windows interface. All hidden files are shown. Those less files don’t exist. I’m guessing it has something to do with Pydio being installed on a QNAP NAS.

I’ve tried every recommendation I can find, including manipulating the database tables. Nothing has worked. Still fails with a RW error. If I know what folders to change permissions for and how to do it I think the issue could be resolved.


#8

Hi,
i reproduced the issue, from scratch and i also happened to forget to add the rights with chmod but once done it fixed everything here’s all the screenshots of my steps,


#9

Thanks for the effort and the screens.
Unfortunately, I’m not quite that savvy where CLI comes in. I am not sure how I would go about this on the QNAP NAS. Also, wonder how those commands work if the files don’t exist. Will the less files be created when running those commands?

Your error message provides an exact path to resolve the issue. Mine is much broader.


#10

Hi,
your error seems to point to a rights issue, because pydio cannot write he couldn’t do the check and then upgrade.

edit : if you could have access through a console and check the rights with a cmd such as ls it would be really helpful


#11

I can ssh in to the NAS but not sure how to proceed from that point.


#12

Hi,
sorry for the late reply, what you could do is use a command such as ls -l when your in the folder containing your pydio installation i would like to see the user:group and the rights.


#13

I decided to try again as I really miss using Pydio.

This is what I have thus far, is this the info that you need?

image

If not, let me know. Now that I figured out how to see the permissions I can navigate through to whatever folder(s) or file(s) are causing the Fail.


#14

Hi,
i see that the owner is the admin, and therefore it cannot write(some have captain as owner) so you have two ways to fix that, you either give it rights with chmod -R 770 <pydio> for instance or use chown -R captain:captain <pydio> to change the owner of everything in pydio,
usually the owner should be the one launching the webservice( for example on linux the user handling apache is www-data by design, you actually can change it but it’s for another subject)