[solved] Grey screen stuck in the loading

Hello!
Again, i have all ready running pydio behind my reverse proxy, although i can see my service running, after i finish my install process i can’t see the login screen, i have a stucked gray page in a loading state…

I try solve it following the steps which i found in this documentation
https://pydio.com/fr/docs/cells/v1/troubleshooting

But the problem persist…

Actually i have Pydio Cells running behind apache proxy, and this is my configuration:

    AllowEncodedSlashes On
    RewriteEngine On
    AllowEncodedSlashes On
    RewriteEngine On
    
    # Proxy WebSocket
    RewriteCond %{HTTP:Upgrade} =websocket [NC]
    RewriteRule /(.*)           wss://127.0.0.1:8080/$1 [P,L]

    ProxyPass "/" "http://127.0.0.1:8080/"
    ProxyPassReverse "/" "http://127.0.0.1:8080/"

This is my Cells install process:

-bash-4.2$ ./cells install
[Configs] Upgrading: setting default config services/pydio.grpc.auth/dex/issuer to /auth/dex
[Configs] successfully saved config after upgrade - Reloading from source

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data

  • IPs and ports for binding the webserver to outside world
  • MySQL 5.6+ (or MariaDB equivalent) server access
    Pick your installation mode when you are ready.

:heavy_check_mark: Browser-based (requires a browser access)
:heavy_check_mark: Other: 127.0.0.1:8080
:heavy_check_mark: Disable SSL (not recommended)
:heavy_check_mark: External Url, used to access application from outside world (it can differ from internal url if you are behind a proxy or inside a private network): https://127.0.0.1:8080
Cannot find vaultKeyPath, creating new one /opt/pydio/.config/pydio/cells/cells-vault-key


 Warning! A keyring is not found on this machine,         
    A Master Key has been created for cyphering secrets       

It has been stored in /opt/pydio/.config/pydio/cells/cells-vault-key
Please make sure to secure this file and update the configs
with its new location, under the defaults/keyPath key.


2019-03-19T13:35:39.972-0600 INFO Registering /install/events for Polling
2019-03-19T13:35:39.973-0600 INFO pydio.rest.install started
Activating privacy features… done.
http://127.0.0.1:8080
WARNING: File descriptor limit 1024 is too low for production servers. At least 8192 is recommended. Fix with “ulimit -n 8192”.

Installation Server is starting …
internal URL: http://127.0.0.1:8080
external URL: https://127.0.0.1:8080

2019-03-19T13:35:40.869-0600 INFO pydio.gateway.rest started
2019-03-19T13:35:42.174-0600 INFO pydio.gateway.proxy Restarting proxy {“caddyfile”: "\n\t\t http://127.0.0.1:8080 {\n\t\t\t root “/opt/pydio/.config/pydio/cells/static/install”\n
\t\t\t proxy /install 172.31.12.180:41503\n\t\t\t \n\t\t }\n\t "}
2019-03-19T13:35:42.174-0600 INFO pydio.gateway.proxy Restart done

Opening URL https://127.0.0.1:8080 in your browser. Please copy/paste it if the browser is not on the same machine.

What i doing wrong??

Thanks againt for the support, and sorry for my english!

Hi,

because you are redirecting http, you should put ws(just one s)

Helo, thanks for the help, but the problem persist if i change that…

let’s do a quick review of everyhting,

what address do you want to use to access pydio (your proxy address i mean),
then what address did you use to bind cells (and ports too).

Now i solve it, just i make a clean install and all works fine with the same configurations which i have :smiley:

Thanks for your help