[Solved] Cells Sync does not want to work with Pydio Cells 2.0.4 (windows server)

I have attached a photo of my problem.

I installed Pydio Cells Server 2.0.4 on my Windows Server 2016 machine with MySQL 8.
During my installation, I had to create a cert and key using openssl and attach them to the installation.
Although my cert is not a trusted CA, I am able to access the service from my local machine once I accept the risk (using chrome)

On Cells Sync I could manage to add the user, however once I try to “download” the folder structure from the server, I get the attached error:
“the gRPC port may not be correctly opened in the server”

I have tried numerous approaches, using TLS and not, opening the required ports on the firewall etc, however to no avail.

I now ask the community for help as I’m out of ideas


Hello @Gawie-Schneider,

Could you answer a couple of question to help me have an idea about your setup.

  • Are you using Cells behind a reverse proxy?
  • Are you using a self-signed or a certificate from a know authority?

Hi Zayn,

as I’ve mentioned, I’m using a self signed certificate I created with OpenSSL.

It would seem though however I’ve managed to bypass this by downloading an unofficial updated version of the Cells Sync application from here


I was now able to download folders, and successfully sync