[SOLVED] Cells + Sycthing + Docker | Error -- Cross Device Mounts Detected

#1
Ts : 1553621115
Level : info
Logger : pydio.grpc.data.objects.local2
Msg : Cross-device mounts detected on path (/root/storage) at following locations [/root/storage/syncdrive]. Export path should not have any sub-mounts, refusing to start. Invalid command line arguments
SpanUuid : span-28

What is it that I’m trying to accomplish:
Syncthing (Container) has a directory (local) that keep a two way sync between my server and local computer. I would like that directory (also local to cells) visible within cells (container).

I’m able to successfully mount the storage, and exec into the container and see expected working results. However when attempting to utilize it, it appears that cells rejects it outright and the storage is not available. Any solution to this?

#2

Hi
Not sure if it’s linked to the fact that cells is running inside a container.
Can you trying mounting the sync directory on e.g. /root/storage/syncdrive and create a datasource that would point to a subfolder of it e.g. /root/storage/syncdrive/data ?
-c

#3

Interesting solution (fixed it). I guess this means items cant be at root directories of a mapped drive. It does add what I feel is an unnecessary extra directory, but that is a small small price to pay for such functionality.

(This is my solution while the desktop sync app is still under development for Cells)

#4

Cool, glad to know - that’s super interesting in fact, Syncthing is written in go so maybe we could work with them on a deeper integration…