Cross-device mounts detected on path

Level : info
Logger :
Msg : ERROR Invalid command line arguments: Cross-device mounts detected on path (/media) at following locations [/media/media02]. Export path should not have any sub-mounts, refusing to start.
Ts : 1675391040
SpanUuid : span-5

This is a binary install.
I am choosing the import data option.
I have had the same problem trying to implement the flat option.
There is a folder on the NAS already hence the import data option.

The mount instruction is: on /media/media02
In case it matters this a synolgy nas ds220. I am also running smb on it so I can see the disk from my windows work station.

in addition I have tried mapping to just /mnt or /media - but I can see the interface requires a 2nd level.
Also I tried a three level map such as /volume1/Media02 on /media/media02/top - this failed with the same error.

the media folder is owned by the user running cells - permission rwx for everybody
the media02 folder is owned by the user running cells - permission rwx for everybody

Just as a point of comparison I mounted a usb drive at /media/usb-drive and I get the same error when creating a storage entry.

What should I be looking at next.


Level : info
Logger :
Msg : Error: Rename across devices not allowed, please fix your backend configuration (/opt/start/.minio.sys/tmp/9edbae8c-f266-4416-ba45-d31982976c61/d8dc6d6e-3cba-4db3-977d-22597c396aa2)->(/opt/start/datalink/.pydio) (*fmt.wrapError)
Ts : 1675450751
SpanUuid : span-8

I have come across a post on this site that recommended using links in the setup instead of the direct reference to the share folder assigned in the mount. I tried that and was able to get the service to run but it failed to sync the data with the above error.

I am really stuck here without the ability to connect to some large data store I will have to use a less desirable server application like own or next (cloud).

Any help will be appreciated.

I run unraid. Used the linuxserver image, but mounted /config/data to a custom share. That seemed to work fine so I wanted to add a workspace for my media as well. I added a volume that points to the media share and tried adding a data source. Result is the same as what you have. It’s frustrating since I really like the software, but it is a very important feature for me.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.