[Solved] ./cells-ctl data sync fails with Internal Server Error


#1

When I run: “./cells-ctl data sync” I get the following error:

Resync Failed: {“id”:“go.micro.client”,“code”:500,“detail”:“none available”,“status”:“Internal Server Error”}
[Time taken : 102.336273ms]

I get the error with or without specifying a source. Ideas?

Environment versions:

Host:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

App:

Cells: 1.2.3


#2

Hi,
it’s seems to be a bug, we are looking at it and we will release a cell-ctl binary,
i will try to keep you updated but in any case keep an eye on our public repository.


#3

I posted a GitHub issue earlier if that matter.

https://github.com/pydio/cells/issues/43

Thanks,


#4

It was indeed a bug which will be fixed the next release. Assuming version 1.2.4 since current version is 1.2.3


#5

Hi,
yes it’s fixed on our 1.2.4 release, it will be released in a couple of days if you want to use the fixed cells-ctl you can get it from our public repo https://download.pydio.com/pub/cells/release/1.2.4/linux-amd64/


#6

Hey, thanks for the quick response and release. I dowloaded version 1.2.4 of cells-ctl and tried the command as follow:

./cells-ctl data sync --service=pydio.grpc.data.sync.personal --path=/datastore/pydio-data/personal/

but all I get is:

Resync Failed: context deadline exceeded

Resync Failed: {“id”:“go.micro.client”,“code”:408,“detail”:“context deadline exceeded”,“status”:“Request Timeout”}

[Time taken : 30m0.000593868s]

Am I still missing something?

Thanks,

Yannick


#7

Hi,
my bad, then you should wait for the official release, it could be that you need cells & cells-ctl both version 1.2.4.


#8

So yes, using both cells and cells-ctl from version 1.2.4 works :smiley:

Thanks again.

Yannick


#9