Since a few days (Nothing changed by me) pydio dead with error-msg

We had a working Pydio 8 installation. All ok and we used it a lot already. Now, since like 10 days, login-page is white and Text “Blocking error encountered, please check the server logs: ‘There was an error trying to connect to your database! Did you change any configuration for the core connection? Or maybe your database is down?’”

Error-Log shows:
[02-Oct-2019 22:15:42 Europe/Zurich] Error while trying to write to logger: There was an error trying to connect to your database! Did you change any configuration for the core connection? Or maybe your database is down?
[02-Oct-2019 22:15:42 Europe/Zurich] Exception was caught but could not be logged properly: There was an error trying to connect to your database! Did you change any configuration for the core connection? Or maybe your database is down? in /home/bvbzz/public_html/bv-bern/pydio/plugins/conf.sql/SqlConfDriver.php on line 113
[02-Oct-2019 22:15:42 Europe/Zurich] ===> Exception details : /home/bvbzz/public_html/bv-bern/pydio/plugins/conf.sql/SqlConfDriver.php on line 113 #0 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/PluginFramework/PluginsService.php(568): Pydio\Conf\Sql\SqlConfDriver->init(Object(Pydio\Core\Model\Context), Array)
#1 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Services/ConfService.php(192): Pydio\Core\PluginFramework\PluginsService->softLoad(‘conf.sql’, Array)
#2 /home/bvbzz/public_html/bv-bern/pydio/plugins/core.conf/CoreConfLoader.php(54): Pydio\Core\Services\ConfService::instanciatePluginFromGlobalParams(Array, ‘Pydio\Conf\Core…’, Object(Pydio\Core\PluginFramework\PluginsService))
#3 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Services/ConfService.php(251): Pydio\Conf\Core\CoreConfLoader->getImplementation()
#4 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Services/ConfService.php(116): Pydio\Core\Services\ConfService::getConfStorageImpl()
#5 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Services/ConfService.php(102): Pydio\Core\Services\ConfService->startInst()
#6 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Http/Base.php(72): Pydio\Core\Services\ConfService::start()
#7 [internal function]: Pydio\Core\Http\Base::handleRoute(’/pydio’, ‘/’, Array)
#8 /home/bvbzz/public_html/bv-bern/pydio/core/src/pydio/Core/Http/TopLevelRouter.php(139): call_user_func(Array, ‘/pydio’, ‘/’, Array)
#9 /home/bvbzz/public_html/bv-bern/pydio/index.php(30): Pydio\Core\Http\TopLevelRouter->route()

If i do a SQL-DB-check on the host (, the DB is valid.
Also, i ran pydio/…/runTests.php (after uncommenting the DIE and all is OK.
Tested all versions of PHP on this domain from 5.5.6 to 7.0, 7.1, 7.2, 7.3 up to 7.4. None showed progress in that.

As i seem to have lost the connection to the DB, how can i “reconnect” Pydio to my SQL again without working GUI?

Please provide the following tags: install / upgrade, package type, server OS, pydio version
Was fresh Installed and after config untouched. Stopped working after like 3 months.
Package: i think i installed it via zip.
Server OS: Suspect Unix, but not sure. How to find out?
Pydio version: Pydio Core 8.2.3

Are you able to connect to files of Pydio? If it’s possible, please look for bootstrap.json file in PYDIO_INSTALL/data/plugins/boot.conf

This file contents all information about DB connection.

Another things should be verify in this file is: driver_mysqli=true/false. With php version 7, it should be true. And mysqli extension should be present in php as well.

I have full FTP- and filemanager- (tool of my website-ISP) access.
The credentials seem correct to connect to the DB. I even added another user and tested his username and credentials. Same result.
The driver_mysqli=true however is not found in this JSON-file. See redacted (for passwords) contents of data/plugins/boot.conf/bootstrap.json :

      "mysql_password":"REDACTED OF COURSE",

Where to put the driver_mysqli=true ?

And no idea what you mean with
“And mysqli extension should be present in php as well”
Sorry… :frowning:

Edit: If it is of any help, i also have phpMyAdmin-access to the Database…

Edit2: We (the ISP and I) are now trying to revert back to the Backup of 3 days bevore the first error. Lets see if this helps…

Hi, sorry, I mean this param.

For quick check, you can place a info.php file into root of Pydio folder which content phpinfo(); function and browse it. From the result rendered by phpinfo() function please search for mysqli information

Thanks for the inputs.
Find the mysql-section of phpinfo(); below:


MysqlI Support enabled
Client API library version mysqlnd 5.0.12-dev - 20150407 - Id: 38fea24f2847fa7519001be390c98ae0acafe387
Active Persistent Links 0
Inactive Persistent Links 0
Active Links 0
Directive Local Value Master Value
mysqli.allow_local_infile On On
mysqli.allow_persistent On On
mysqli.default_host no value no value
mysqli.default_port 3306 3306
mysqli.default_pw no value no value
mysqli.default_socket no value no value
mysqli.default_user no value no value
mysqli.max_links Unlimited Unlimited
mysqli.max_persistent Unlimited Unlimited
mysqli.reconnect Off Off
mysqli.rollback_on_cached_plink Off Off

Is it save to attach / link to the full file?

Edit: Seems i am not allowed to attach images yet… Pasting text instead.

Also: The ISP told my just now, that they installed a bunch of security updates (Mail (i dont care) and stuff like IPv6 (Which could be something?)) on the day it started to fail. Could that (like IPv6-Updates) be a source of problems? worth investigating or a red herring?

Oh good news! Pydio works again.
in the config had to be changed to

This was installed with as host by the installer of pydio. It may be worth to take a look there and optimise the installer?