Can't run after moving to another host (db error but bootstrap.json ok)


I have a Pydio 8 installation running in one server and after copying it to another server, the application doesn’t run, the error reported is:

[Sun Nov 29 15:27:07.764898 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: PHP Fatal error: Uncaught exception 'Pydio\\Core\\Exception\\PydioException' with message 'Severe error while loading plugins registry : There was an error trying to connect to your database! Did you change any configuration for the core connection? Or maybe your database is down?' in /home/xxxx/apps/pydio_dir/core/src/pydio/Core/PluginFramework/PluginsService.php:819
[Sun Nov 29 15:27:07.764964 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: Stack trace:
[Sun Nov 29 15:27:07.765190 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: #0 /home/xxxx/apps/pydio_dir/core/src/pydio/Core/PluginFramework/PluginsService.php(203): Pydio\\Core\\PluginFramework\\PluginsService->getDetectedPlugins()
[Sun Nov 29 15:27:07.765436 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: #1 /home/xxxx/apps/pydio_dir/core/src/pydio/Core/Services/ConfService.php(392): Pydio\\Core\\PluginFramework\\PluginsService::getInstance(Object(Pydio\\Core\\Model\\Context))
[Sun Nov 29 15:27:07.765628 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: #2 /home/xxxx/apps/pydio_dir/core/src/pydio/Core/Http/Base.php(62): Pydio\\Core\\Services\\ConfService::getGlobalConf('ADMIN_URI')
[Sun Nov 29 15:27:07.765729 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: #3 [internal function]: Pydio\\Core\\Http\\Base::handleRoute('', '/', Array)
[Sun Nov 29 15:27:07.765987 2020] [cgi:error] [pid 45876] [client xxxx:33620] AH01215: #4 /home/xxxx/apps/pydio_dir/core/src/pydio/Core/Http/TopLevelRouter.p in /home/xxxx/apps/pydio_dir/core/src/pydio/Core/PluginFramework/PluginsService.php on line 819

The php version in both servers is the same PHP 5.6. After copying it to the new server, I modified the mysql login details in data/plugins/boot.conf/bootstrap.json. I’ve checked that the login credentials are right.

I don’t have cache files (*.ser) in data/cache/

Could anyone give me some advise in order to fix the issue?

Thank you very much!

Please make sure you installed php-mysql (php-mysqli) and correct mysqli option in bootstratp.json

I will check it but other php-mysql applications work in the server. I will also try the migration to cells.

I’ve tried to install and run cells but I could do that in my shared hosting and also it consumes a lot of memory I don’t have.
I checked that I have mysql and mysqli extension activated in PHP and the tight credentials in the bootstrap.json file
My previous host uses MySQL 5 and the new one MariaDB 10. Could be something related to that?
Any other advise on how to find the issue?

I tried a fresh installation of pydio 8.2.5 and it works perfectly so I finally “moved” the users and data from the old installation to the new one.

This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.