Really old external packages in the default installation for pdf viewer


#1

After a new install I have noticed that pdf.js is a really old version 1.1.215 that has several issues in decoding well formed PDF file.
I have locally updated the packages to v1.9.426 and pydio now works properly.
I will suggest the package maintainers to have a look to those external dependencies to keep pydio up-to-date.
Otherwise, likewise is done for other plugins, leave the user the duty to download and install latest release of the javascript library.


#2

As far as I know, that issue hadn’t been resolved by a month ago. So everything one can do here yet is to update the packages manually. I don’t appreciate being forced to figure it out in such a fashion, so purchased a one-month subscription for this tool to try, but it’s appeared as a tool to work with fillable forms actually, like ds11 and else. If anyone would recommend something more capable of doing full editing, I’m all ears