Rather urgent issue with v2.2.x

We really need some quick help on this as it is preventing users from using the program :frowning:

I recently upgraded from v2.0.9 to v2.2.2 in order to resolve some issues. However, now that I’ve upgraded our users can no longer create new Cells. Existing Cells are ok.

When users try to create Cells they get the following error:

Ts : 1613749356
Level : error
Logger : pydio.rest.share
Msg : Rest Error 403 - {"id":"folder.share-internal.forbidden","code":403,"detail":"You are not allowed to create Cells on folders","status":"Forbidden"}
UserName : admin
UserUuid : 6f59b8af-2090-432a-b7e9-77eff26d84e7
GroupPath : /
RemoteAddress : 135.23.74.229
UserAgent : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0
HttpProtocol : HTTP/1.1
SpanUuid : 16c25842-72c9-11eb-a465-005056b3f826

We do have one thing different from most setups, we created a Workspace that points to the cellsdata folder so that an Administrator can access all users files through the Rest endpoints for workspaces. I thought maybe the error was saying that this isn’t allowed anymore, but even after deleting this workspace the error above continues to persist.

1 Like

Ok, I figured this out myself. The issue turned out to be that I had changed settings in the “Sharing Features” plugin to disallow users from sharing files/folders and somehow this setting is now preventing users from creating Cells at all.

Pydio devs, please review how and why this change was made as the undocumented change caused us a lot of grief. Also, I don’t understand why this change was made, the name of the setting “Enable internal folder sharing” gives no indication that this should affect Cell creation.

FWIW I turned off this setting in v2.0.9 because it conveniently turned off the “Sharing this folder with other users by creating a new cell” part of the link sharing UI. This particular feature is unnecessary and confusing to our users and costs IT support some time trying to explain they shouldn’t touch it. Now that v2.2 seems to have changed how this works, we don’t seem to have any way to hide that part of the UI anymore :frowning: