Pydio server 8.2.2 Fatall Error informaniak deployment


#1

Hello Everyone! Since I wanted to update to the last pydio server version I’m having a fatal error showing that is anyone know how to fix it or what is it relative to ?

Fatal error : Uncaught RuntimeException: Output has been emitted previously; cannot emit response in /home/clients/web/network/core/vendor/zendframework/zend-diactoros/src/Response/SapiEmitterTrait.php:41 Stack trace: #0 /home/clients/web/network/core/vendor/zendframework/zend-diactoros/src/Response/SapiEmitter.php(30): Zend\Diactoros\Response\SapiEmitter->assertNoPreviousOutput() #1 /home/clients/web/network/core/src/pydio/Core/Http/Middleware/SapiMiddleware.php(145): Zend\Diactoros\Response\SapiEmitter->emit(Object(Zend\Diactoros\Response\HtmlResponse)) #2 /home/clients/web/network/core/src/pydio/Core/Http/Middleware/SapiMiddleware.php(81): Pydio\Core\Http\Middleware\SapiMiddleware->emitResponse(Object(Zend\Diactoros\ServerRequest), Object(Zend\Diactoros\Response\HtmlResponse)) #3 [internal function]: Pydio\Core\Http\Middleware\SapiMiddleware->handleRequest(Object(Zend\Diactoros\ServerReques in /home/clients/web/network/core/vendor/zendframework/zend-diactoros/src/Response/SapiEmitterTrait.php on line 41


#2

Hi,

This error does not content useful information.
First check the requirements of Pydio: https://pydio.com/en/docs/v8/pydio-requirements
Could you please detail the php version, OS name and pydio version before update.


#3

I’m using the latest version of PHP (7.3) pydio 8.2.2 on a apach server


#4

Hi,

Please try with PHP7.2


#5

Still the same. It doesnt bloc from using it but at the very beginning I’m all the time having this message downthe page


#6

Hi,

Login with admin from web interface,
Then comment out these lines (113, 114) in core to see what’s happened.