PYDIO 8 page not found


#1

Hello
I have installed Install PYDIO 8
UBUNTU 16.04.4 LTS
Apache2 version Server version: Apache/2.4.18 (Ubuntu)
Server built: 2017-09-18T15:09:02,
PHP version Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies, with Zend OPcache v7.0.28-0ubuntu0.16.04.1, Copyright © 1999-2017, by Zend Technologies
Pydio 8 run correctly with the command 192.168.1.65/pydio.
If I try to acces from http://mysite.org, the result is page not found. if i try an acces without pydio Vhost, I fount the UBUNTU APACHE2 test page
With the cmd apache2ctl -S I have this error:
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 192.168.1.65. Set the ‘ServerName’ directive globally to suppress this message
VirtualHost configuration: *:80 mysite.org (/etc/apache2/sites-enabled/mysite.conf:3
I think that Apache start with a file.html and Pydio is a php file, I don’t found how change this configuration
Tank you
Laurent


#2

Hi,
i think that you don’t have php, could you tell me with the command php -v what is your version.


#3

Hi Zayn
My PHP version:
PHP 7.0.28-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.28-0ubuntu0.16.04.1, Copyright © 1999-2017, by Zend Technologies
Laurent


#4

Hi,
yes fair enough you should have php, maybe you could try to create an index.php and put <? phpinfo(); ?> in the folder situated in /var/www/html and use the default virtual host file that should point to this and then see if it shows you a php info page.


#5

Hello
the result is a blank page !
Laurent


#6

Hello
Correction I have the php info page displayed !
Laurent


#7

Hello
I have some news: to start Pydio with apache2 I use the index.php file in the /usr/share/pydio folder. The index.php code is:
use Pydio\Core\Http\TopLevelRouter;use Pydio\Core\Http\TopLevelRouter;
include_once(“base.conf.php”);
$router = new TopLevelRouter();
$router->route();
But the folder pydio/core/http does not existe! The question is : is it the correct index.php?
I think that Pydio is correctly installed because it run correctly with 192.168.xx.xx/pydio command.
Some one can help me?


#8

Hi,
your php seems to work fine but your issue is weird, in your virtual host file if you told apache where Pydio is it should work properly, could you show me your virtual host file, and for the installation of Pydio 8 what was the method that you used.


#9

Hi
I make the installation of PYDIO from the PYDIO site, If I try to acces PYDIO directly with FireFox (192.168.1.65/Pydio) it’s OK PYDIO starts and run correctly, the problem is only when I try to acces to Pydio true http. For this time I test it with the port 80, but after it will be the port 443
MY VHost:

#
<VirtualHost *:80>
ServerAdmin webmaster@localhost
ServerName http://gueneryfamily.hopto.org
ServerAlias gueneryfamily.hopto.org
DocumentRoot /usr/share/pydio

Options FollowSymLinks
AllowOverride None

<Directory /usr/share/pydio>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory “/usr/lib/cgi-bin”>
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all

ErrorLog {APACHE_LOG_DIR}/error.log LogLevel warn CustomLog {APACHE_LOG_DIR}/ssl_access.log combined
<Directory “/usr/share/pydio”>
Options FollowSymLinks
AllowOverride Limit FileInfo
Order deny,allow
Allow from all

SSLEngine off

By Laurent

#10

Hi,
this issue is either on apache side or that you did not put the right domain name, what you could try is edit your browsing computer’s /etc/hosts file and something like this gueneryfamily.hopto.org = 192.168.1.65 and see if it works then we will see the issue further.


#11

Hi
I make some tests

  1. in the folder /usr/share/pydio I put the index.html from ubuntu it’s ok when i try to acces at my URL I can see the Ubuntu test page, (from my smartphone also) for me apache is ok now.
  2. after removing the index.html in the file index.php of pydio, I write a ligne with an error, when I try to acces it, I have a syntax error. so apache2 read the index.php
  3. I remove the error, and I try to acces it the result is page not found
  4. in firefox I send: 192.168.1.65/Pydio, it’s ok Pydio run correctly
    For me the configuration of apache2 is correct now (whith your last answer),
    I think that the index.php is not correct, I don’t know where the correct index file is located

#12

Hi @laurent53240

As I understand as when you are trying to access to your pydio server with the FQDN, you got a blank page but with the IP address and “/pydio” you access to the login page.

First question :
In Pydio server, Do you have the DNS server in “/etc/resolv.conf” ?
Second question :
Pydio can communicate with your DNS server ?

Here’s what I advice you :

  • enable ssl (a2enmod ssl)
  • create a new VH : (Create pydio.conf in /etc/apache2/site-available/)

<VirtualHost *:443>

SSLEngine on

DocumentRoot /usr/share/pydio
ServerName Your_PYDIO
<Directory “/usr/share/pydio”>
Options FollowSymLinks
AllowOverride Limit FileInfo
Order allow,deny
Allow from all

ErrorLog ${APACHE_LOG_DIR}/pydio_error.log

LogLevel warn

CustomLog ${APACHE_LOG_DIR}/pydio_access.log combined
SSLProxyEngine on
SSLCertificateFile /etc/ssl/certs/YOUR_CERTIFICATE
SSLCertificateKeyFile /etc/ssl/private/YOUR_CERTIFICATE

Then, enable it : a2ensite pydio.conf

  • in /etc/pydio/htaccess remove “/pydio” in RewriteBase and add “/”

If all goes well, you can access to pydio with : https://fqdn and https://IP_Server

Do not forget to reload apache2 !
EDIT : 2 lines will not display, so do not forget :

  • add the </directory (with a “>” at the end) after “Allow from all”
  • add the </VirtualHost (with a “>” at the end) after “SSLCertif…”

I hope that help.

Malcolm


#13

Hello Malcolmp
I try your solution, always “page not found” (the port 80 of the box is turned off)
The ssl function is ok. (I use let’s encrypt for the certificates)
In the new vhost file, I replace the line <Directory “/usr/share/pydio”> by this line <Directory “/var/www/html”> the Ubuntu test page is displayed correctly !
If i write a new test index.php file in the usr/share/pydio folder the result is ok
It seem that the problem is with index.php of Pydio, but the IP adress /pydio use this file, (The ubuntu page is displayed when I use the test index.php)
So I don’t understand where is the problem
Laurent


#14

Hi,

That is really weird.

Did you remove “/pydio” in /etc/pydio/htaccess like this :


#15

Hello Malcom
Yes, my htacces is exactly the same.
Laurent


#16

Hi Laurent,

I’m sorry but your problem is outside my area of expertise there and I can’t help you.

Good luck!

Last Advice, install pydio on CentOS!!!

Malcolm


#17

Hello Malcom
I try https://G…org/pydio it’s ok !!
it seem that is a path problem.
Thank you for your help


#18

Hi,

A path problem with a Document Root ?


#19

Hi
I don’t think so, because if I replace the index.php of pydio by my test index.php it’s ok
my index.php for test:

<?php phpinfo(); ?>

It seem that the path inside the Vhost file is correct.


#20

Hi,
Please consult this page: https://pydio.com/en/docs/kb/legacy/fix-public-link-after-upgrading-pydio-7

and don’t forget remove /etc/apache2/confs-enabled/pydio.conf if you install Pydio by apt