Pydio 8 - Can't find where the wizard installed, How to uninstall wizard install?

apache
ubuntu

#1

Hello,
I have an ubuntu 18 server, with multiple virtualhosts in apache linked to multiple domains/websites. the virtualhosts files are in /etc/apache2/sites-available, the websites in /var/www/.
I’d like to install pydio on multiple websites, if possible on a subdomain such as file.MyDomain.com

I’ve just run the wizard at OneOfMyDomains/pydio, tried inputting “file.OneOfMyDomains.com” as the install url, the wizard completed and redirected me to a blank page (dev console gives 404 errors while trying to load resources).

I’ve searched in all the common places (/var/www/??, /etc/apache2/sites-available/??, tried searching for files containing “pydio” in their name…) but cannot find where the wizard installed or tried to install the files. I’ve found some general conf files which don’t seem to contain anything related to my install attempt.

Is there a way to remove a wizard installation ? Where are the files or conf files installed by the wizard ?

Thank you in advance for your time, I apologize if these questions seem trivial but i’m very confused.


#2

Hi,
did you install pydio by download the archive in /var/www or did you use the packages method ?
For the redirection it could be a rewrite rules issue, enable them using a2enmod rewrite.


#3

I’ve figured out since then that installing it by archive keeps it all nice and tidy wherever you put it and allows me to have multiple installs for multiple virtual hosts. I still have no idea how it installed with packages.

I’ve since given up using this. Migrating previous installs breaks it most of the time even with the same version and same path, manually upgrading/converting old DBs is a pain, exporting/importing users isn’t doable (for free), strange errors in versions 7.1 and 7.2 of php (with no warning before installation to not use those versions), all in all this just seems annoying to install and maintain. Adding to that vague documentation, never explained that the package vs archive installation was this different, to the point where a package installation is completely useless to me, doesn’t tell me where it puts things and gives me no information that I might use to fix/customize it.
Nevermind the fact that apparently the latest version (cells, which I originally tried to use) doesn’t seem to be easily compatible with an apache install unless changing the default ports it uses (god why?).

This seems like a really cool thing once it’s properly installed and configured, don’t get me wrong, but It feels like it makes no effort to let you properly install, fix or migrate it.

thanks for the help though !


#4

Hi,
sorry to hear this,

For this type of installation, you would have to add the repositories and then do an apt-get install pydio, so it couldn’t be done alone, then it might be that you did not even install it unless you did it.

for this fact, it’s because we have integrated a web server(caddy) with the cells binary if you want you can put a reverse proxy, so you cannot use 2 port 80, for instance you would have to either proxy or, put on 80 and another on 8080.


#5

Sorry if I got ranty/angry. This is a cool app, I’ve found a way to install version 8 and (slowly) transfer/convert previous files and DBs for it, although it’s a bit of a pain.
I understand the reasoning for the cells version as well, but considering i’ve never had to do much in terms of server config, when I see “changing default ports” and “reverse proxy” and I have to setup multiple of these pydio installs and make them work with lots of websites and other things, It does not make me feel confident.

Honestly, the vague/lackluster documentation is the worst part.

Thanks for your help.


#6

yeah, the archive install is kinda tricky, I will talk with my colleagues and add more details about where every folder is created ( usually it should follow the same pattern of every package installation).