Proxying GRPC through nginx


I’m trying to proxy GRPC for cells sync through a nginx frontend server. I found the following snippet in your manual:

server {
    listen 33060 ssl http2;
    listen [::]:33060 ssl http2;
    ssl_protocols       TLSv1 TLSv1.1 TLSv1.2;
    ssl_ciphers         HIGH:!aNULL:!MD5;
    keepalive_timeout 600s;

    location / {
        grpc_pass grpcs://;

  error_log /var/log/nginx/proxy-grpc-error.log;
  access_log /var/log/nginx/proxy-grpc-access.log;

Unfortunately, this can’t work, because if nginx is listening on port 33060, cells can’t also listen on the same port. Setting different ports for both doesn’t work either (because the API advertises the wrong port to clients?).

Any ideas on this one?

Kind regards

This config assumes the nginx is running on another machine.