Cells Sync on UNRAID

I have installed the pydio cells docker on unraid ver 6.9.2 and it is working. I used a reverse proxy NginxProxyManager docker and generated a sub domain https://pydio,mydomain.com… I can access pydio cells WORKSPACES. I can upload and drag and drop without any connection errors.

Nginx Reverse Proxy Setup:

-------------------------------
pydio.mydomain.com
-------------------------------
server {
set $forward_scheme https;
set $server “mydomain.com”;
set $port 8080;

listen 8080;
listen [::]:8080;

listen 4443 ssl http2;
listen [::]:4443;

server_name pydio.mydomain.com;

Let’s Encrypt SSL
include conf.d/include/letsencrypt-acme-challenge.conf;
include conf.d/include/ssl-ciphers.conf;
ssl_certificate /etc/letsencrypt/live/npm-62/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/npm-62/privkey.pem;


CREATE TASK - using Cell Sync - THIS DOESN’T WORK! :hot_face:

Click on create a sync task and app opens requesting:

Cells Server (SSL) - Login to a new server - https://pydio.mydomain.com… I login with the admin account.

Cells Sync Pick a folder, returns a pink banner “server closed the stream without sending trailers”

REMINDERS: This is a Unraid/Docker build.
I can supply logs if needed - I am a newbie but work hard.

Hello @vmattaur

Assuming that this is your complete nginx reverse proxy config, I believe what you are missing is a directive about grpc, Cells-Sync uses grpc for some operations and Cells exposes some grpc, but it could be that you did not have that enabled in your reverse proxy.

To do that you must add the following line in your nginx conf:

location / {
        grpc_pass grpcs://localhost:8080;
    }

In this localhost is the host on which cells is running and 8080 is the port under which cells is bound.

What this will do is redirect all the grpc traffic that is in coming on your nginx to → Cells.