Problem after install


#1

Hello People,

I first install the new Version of Ajax. When I get to the point Repositories and Users I get a failure Message, the failure Message is
“file_get_contents (http://ajaxplorer.info/update/?channel=stable&version= 5.0.0) failed to open stream; HTTP request failed! HTTP/1.0 404 not found”

Do anybody know whats the failure is and how i get them solved? I don’t have much experience in php or webserver but i think it’s a module he don’t find or is noch activated. But which and where can i find it? In the php.ini or in the httpd.conf or elsewhere??

THX for Help

Rene


#2

Hi,
could you give me your Pydio Version,
PHP Version, Database Version and also on what os your machine is running.


#3

Hello Zayn,

my OS ist an Windows 10 Professional (revision must i have a look when i’m at home), I’m using xamp with php 5.6.38 an the Maria DB 10.1.36 which is in the xamp Version included and Pydio 7.0.0 I think is the newest I loaded from sourceforge.net.


#4

Hi,
i would advise you to use our latest pydio version 8, (actually the latest is cells but we are still working on the windows support).

Here’s pydio 8 from our public repositories
https://download.pydio.com/pub/core/ci/pydio-latest.tar.gz


#5

Hello zayn,
i updated the pydio version, before i got the pydio version 5.0.0 (ajaxplorer). But I got a new Problem, when I try to open users and groups i get a network failure and there are no users or groups to see. I only can search the users and groups then i get them but not in the overview. Although when i make a new workspace and get them rights etc. i don’t see the workspace anywhere besides the workspace configuration area. So i don’t can give anyone the permissions to access or to see the workspace.


#6

Hi,

Because of action.updater plugin try to connect to ajxplorer.info to get update information. Ajaxplorer is no longer supported and this server is not active. Latest version of Pydio is highly recommended


#7

Yes, as you see in my latest post I installed the Pydio 8.0.0 as zayn give me the link but there are still some other problems with the pydio as you see in my foreign post.
So it would be nice if anyone could help me with these failure. Is there anywhere a log file in pydio that i could post here where anyone could see what’s the problem now with the pydio 8 installation to fix this?


#8

Does nobody have an Idea why I don’t see the Users and Groups in Pydio accept i search for them and why i don’t can give someone Access to a Workspace i created, because i don’t see the Workspace in the Users card?


#9

Hi,
sorry for the delay,
first let’s make sure that you are on Pydio 8.2.2 (you can check in the settings > upgrade).
Now could you tell me how you installed Pydio, your OS, mysql version and php.


#10

Hello zayn,
Yes I have installed the Version 8.2.2. I have an xamp installed on my system with php 5.6.38 and Maria DB 10.1.36.
I created a new sql-database with name pydio, when i installed the pydio i connected the database with the root user because the new created pydio user i created havent got the right (although i gave all rights to the user) to connect to the database.
Within the install i modified the php.ini in the points i find in the admin guide of pydio. My OS is Windows 10 as i said before in my post. :wink:

Greetings
Rene


#11

Hi,
ok you have more or less everything right (if you could update php to 7 it would be wonderful),
now to your users problem,
so you create a workspace and then you want to give your user rights to access the said workspace?
If that’s the case look at the root group (which manages the rights for all the users without a group) and then you give access to this workspace with the group and you should be good to go.


#12

The Problem is that i gave the access to administrators in the workspace but even in the root group where administrators automatic get the rights i don’t see the workspace to gave anyone rights to access to the workspace.
With php 7 i got some problems because i have some other applications that would eventually have problems with php 7 and musst be costumized. As i have not very much experience in php and website programming i would prevent to go to php 7.


#13

Ok so you dont see the workspaces that you created,
did you put something in the following field, (in the workspace menu):


#14

Hello Zayn,

I tried some to fill in there, “root_group” and “Admin” (is member of root_group) but the workspace is not available to configure rights in the admin user or in the root_group. Or must I leave these Field blank?


#15

Hi,
you should let the field empty, otherwise it will be hidden for the users that are not inside the group.


#16

THX Zayn that was the problem, now i can give the right to show the workspace. But the failure with the users is still there. I don’t see the users i created or the system itself had created. Do you have an idea where i can solve this problem? I only find users when i search for it. But in time i don’t know which users i created and don’t find them and can’t delete them.


#17

Hi,
what are the master and secondary driver in your authentication settings.


#18

I don’t know what you mean but i made some Screenshots of the Authentication and the Group and Users folder in the settings. I hope that helps.


#19


#20