Post hidden by community flags

I do not understand why I suddenly get this message:

system
Hello,
This is an automated message from Pydio Forums to let you know that your post was hidden.
Separated groups with separated accesses
Your post was flagged as spam : the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected.
Multiple community members flagged this post before it was hidden, so please consider how you might revise your post to reflect their feedback. You can edit your post after 10 minutes, and it will be automatically unhidden.
However, if the post is hidden by the community a second time, it will remain hidden until handled by staff.
For additional guidance, please refer to our community guidelines.

I got the same message for another post I made under Simple folder access use case - Cannot make it work

I really cannot understand what might be wrong in my postings, since I make a point of always being polite and respectful and stick to the thread’s original subject.

I even received answers for those post before they became considered as spam.

I must say I’m a bit lost here since I neither understand why my post are being rejected (or at least hidden) neither know what to do to modify this situation…

Any hint will be appreciated, a forum’s admin intervention to remedy the situation would be even more welcome.

Thank you.

Hi,
sorry the forum is doing that when people link multiple links, do not worry i will unlock it once i see it.

Thank you @zayn!

It happened for those 2 posts of mine:

You should be good to go, the anti spam system does not like when you link 3 times the same url (in this case ours in the same post), i will add a rule about our own url.