/oidc/.well-known/openid-configuration not found

Hi,

I’m trying to set up the cells-sync client but I’m unable to add my server. When I attempt to add the server I get a “Not Found” response

404 NOT FOUND https://pydio.domain.tld/oidc/.well-known/openid-configuration

I’m running cells-sync 0.9.2, pydio-cells home edition 2.2.9
Pydio-cells is runnign in a docker container behind a caddy server.

My caddy config is as follows

{
    "handler": "reverse_proxy",
    "upstreams": [
        {
            "dial": "pydio:8080"
        }
    ],
    "transport": {
        "protocol": "http",
        "tls": {
            "insecure_skip_verify": true
        }
    }
}

It seems I have the same issue as Cells sync cant connect to my server but there isn’t enough information to confirm.

Any help would be appreciated.

Hello @crobibero ,

Could you share with me your cells sites configuration,
you can use the command ./cells configure sites.

/var/cells # cells configure sites
The following sites are currently defined:
+---+----------------------+-------------+-------------------------+
| # |       BIND(S)        |     TLS     |      EXTERNAL URL       |
+---+----------------------+-------------+-------------------------+
| 0 | https://0.0.0.0:8080 | Self-signed |                        |
+---+----------------------+-------------+-------------------------+

I see that this is probably not correct, so I updated the config to now have the following, and now oidc is responding correctly. I must have missed this step in the docs, can you please link this step so I can see what else I missed?

/var/cells # cells configure sites
The following sites are currently defined:
+---+----------------------+-------------+-------------------------+
| # |       BIND(S)        |     TLS     |      EXTERNAL URL       |
+---+----------------------+-------------+-------------------------+
| 0 | https://0.0.0.0:8080 | Self-signed | https://pydio.domain.tld |
+---+----------------------+-------------+-------------------------+

Hello @crobibero

Indeed you fixed the issue, basically by setting the external address, you are telling cells which URL is valid for the requests.

We might have not emphasized the mandatory status of this setting.

By now your issue should be resolved once you have set an external address, if you encounter other issues tell me in the thread.

Also about the nginx documentation I think that i’m gonna do a big update on it because it seems that I did not emphasize many details that are important on Cells side.

1 Like

Ah that makes sense. I don’t think I found that article as I was specifically looking for Caddy configuration!

Thank you for your replies, I now have a fully working Pydio Cells instance with sync.

oops, I apologize
I was working with nginx since this morning and it seems that I confused Caddy with nginx,
but I will also do the same for the Caddy documentation.