Networking issues on Ubuntu Server

I am trying to install the new Pydio cells to a vps. I have followed instructions from and i am facing the following error

ERROR nats Could not run {“error”: “No private IP address found, and explicit IP not provided”}

I have followed the instructions on the “Networking issues” section of the same page and still can’t seem to resolve the issue.

Anyone has any idea whats the problem and how i could address it?


could you give me the details on your setup, PHP, Ubuntu and Mysql Version.
Then i would like to know/see what you’ve put into the fields for your pydio installation and more importantly the ones that you have on the cli when you use ./cells install.

If your trying to use a real world IP address I’d say your issue is similar to this issue…


Because of security, nats service can run only in local network whose its ip address is in You see this error because this machine has only loopback and public ip.

You can use “IP aliasing” to add to the vps a virtual ip address.

First of all thank you all for the replies.

In the Networking section of

i see this

auto eth0:1
allow-hotplug eth0:1
iface eth0:1 inet static

By running ifconfig i see that my network interface is ens18 and lo.
So i tried to set eth0 to ens18 in the previous script and resulted to

auto ens18:1
allow-hotplug ens18:1
iface ens18:1 inet static

Still the error i get the same error. I attach also a screenshot with the issue and the ifconfig command.

Thank you all very much in advance :slight_smile:


Did you “sudo systemctl restart networking” ?

yeap, Still nothing :confused:

Any hints?

I tried the new version and when i run ./cells start i get this error

pydio@vmi196599:~$ ./cells start
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x28 pc=0xf1769a]

goroutine 275 [running]:*service).Init(0xc4202d9400, 0xc420a52c00, 0x7, 0x7, 0x24, 0x1)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/ +0x31a, 0xc4204f5800, 0x4f454c764e794849, 0x646e54774a493549)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/ +0x4ba*service).Start(0xc4204f5800)
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/ +0x20a
created by
/opt/JetBrains/TeamCity/buildAgent/work/73afa92fb1a910b1/src/ +0xa3

Any idea on how to address this?


The error is still the same. It’s problem of nats service inside Cells.

If “ip alias” does not work, you can simply install docker for creation new local (not loopback) IP address. Then you can start Cells

Sorry for intruding on your thread, but I couldn’t find anywhere in the documentation requirement anything about 2 networks. Could someone point me to the part about 2 NIC requirements?
I created an alias for NIC1 with local IP range, like you did and after that I could start cells.

Hi @hbogner ,