Moving a disabled SSL install to HTTPS with Let's Encrypt


#1

After multiple failures during the installation, I can not get the Let’s Encrypt option during the install to work, so alternatively, I can do no encryption, but is there a way to move my Pydio Cells as to use HTTPS with Let’s Encrypt certificates?

If it helps in knowing, I had to use the internal bind IP as 0.0.0.0:8080 and the external as the network IP address of the Ubuntu 18 LTS PC. My router does have a dynamic DDNS service running that I would like to use for my Let’s Encrypt SSL, so if I need to change anything over in the JSON file, let me know as none of this is obvious to me.


#2

I believe you would need to have your FQDN pointing to your router and the port open. In order for Let’s Encrypt to work, their servers have to be able to communicate with the name and port number or else they can’t issue it. So using an IP address I don’t think will work.
Someone else can let me know if I’m off base. :slightly_smiling_face:


#3

I got the same problem here. To install and getting started I did not want it but I’d like to use Let’s Encrypt now and did not find any way how to do that.


#4

Hi,
do you want to enable lets encrypt on an already installed cells?

if that’s the case you need to add the following to your pydio.json (can be a the begining)

  "cert": {
    "proxy": {
      "caUrl": "https://acme-v01.api.letsencrypt.org/directory",
      "email": "your-mail@mail.com",
      "httpRedir": true,
      "self": false,
      "ssl": true
    }
  },

and depending on the infos that you provided and got from let’s encrypt you would have to change the caUrl & email, also if you are running for instance on port 80, do not forget to change all the occurences in the pydio.json to 443 for instance (or another)