Migration question


I want to use Pydio Cells only with GUI and I think I don’t need sync feature.
Unfortunately it seems that data migration from Pydio 8.2.5 needs this feature?
I am using apache reverse proxy on both servers.

Is there a way to get data import working without adding another proxy? If not do I need another proxy on both servers or only on pydio cells?

Thank you!


I have added a nginx proxy. So no more grpc errors.
But i get this error while importing users, groups and roles:
ERROR pydio.grpc.tasks cannot run action actions.etl.users: no consumer: “text/xml; charset=UTF-8”
What does no consumer mean?

I think its an problem with the reverse proxy.
The log looks like:
{“level”:“info”,“ts”:“2021-03-03T12:53:08Z”,“logger”:“pydio.grpc.tasks”,“msg”:“Starting job manually (triggered by user importer_cells)”,“LogType”:“tasks”,“SpanRootUuid”:“6621e23f-7c1f-11eb-bbd9-00163e2d4e04”,“SpanParentUuid”:“6621e23f-7c1f-11eb-bbd9-00163e2d4e04”,“SpanUuid”:“6782609a-7c1f-11eb-bede-00163e2d4e04”,“OperationUuid”:“pydio8-data-import-04a32ca9”,“SchedulerJobUuid”:“pydio8-data-import”,“SchedulerTaskUuid”:“04a32ca9-1898-496f-bcb8-91cd0e1beea8”,“SchedulerTaskActionPath”:“ROOT”,“RemoteAddress”:“”,“UserAgent”:“Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0”,“ContentType”:“application/json”,“HttpProtocol”:“HTTP/1.1”}

RemoteAdress ist the local one behind the reverse proxy → so how can I change it to the correct one?


The migration is done on cells and the info goes in direction from pydio8 => cells. That means, cells call api of pydio 8 to get imported infos.

The reverse proxy for pydio8 is a good solution and I did it in a migration before.

I’m not sure where does the problem come from but please read carefully this article Migrate Pydio 8 to Cells | Pydio

Hello, thanks for the link.
I have double checked all.
I got the same error message even after non - lxc installation.
I tried with sudo. Also the same message.

Please can you tell me what I can do?

OK, I tried with a new installation of an older version: 2.1.0.
I got the same error: ERROR pydio.grpc.tasks cannot run action actions.etl.users: no consumer: “text/xml; charset=UTF-8” {“OperationUuid”: “pydio8-data-import-d952cb11”}

In the browser console there is everything fine. No errors. Only one statement:
Object { JobUuid: “pydio8-data-import” }

Apache log of pydio 8 (ip replaced by stars): 176...* - admin [07/Mar/2021:14:08:50 +0000] “GET /api/v2/admin/people/?format=json&page=1 HTTP/1.1” 200 376 “-” “Go-http-client/1.1”

I have checked apache.conf and .htaccess of Pydio 8.
shows correctly
response is:
Could not find workspace with id/alias v2
(url is replaced)


Getting authentication token with user credentials

Data returned is not JSON! There is something wrong with the API. Exiting.NULL

I have no idea if this is relevant to your issue or not, but what seems strange to me is that Cells is expecting JSON data but gets text/xml; however, the call you’re making seems to return JSON: GET /api/v2/admin/people/?format=json&page=1

I guess you could try cURL to see what the headers are? (using -i/-I to see them) At some point, I was getting the same issues with nginx and had to force nginx to send application/json for the relevant URLs…

Thank you for the hint.

What I have been trying:
→ error
successful JSON answer
successful JSON answer

OK, I have a look at
It tells that there ist needed a path for example {user}

So I don’t understand why the migration process calls without path?!

php cmd.php -u=admin -p=pass -r=0 -a=people --path=user
→ : Could not find action people

This topic was automatically closed 35 days after the last reply. New replies are no longer allowed.