Logon Unauthorized

We have Pydio Cells installed
Running on Ubuntu 20.04
Behind Nginx reverse proxy
data is being directed to a network share accessible to pydio and mounted in Media.
We have been able to reach the front page and login with no issue, until now.
We started adding roles and workspaces
after adding several roles, we then started adding deny rights to the workspaces for several of the roles
now for some reason we are getting unauthorized at the login page,
this is for all users. no one can login

The error message is “Ladon blocked POST request at /frontend/session. Ladon Response:DefaultDeny:true”

Note:
So, after messing around with this for a while, we decided to see if this was a DB issue. We dropped the db and created a new one created a new admin and user still getting the unauthorized error on login.

Hi

Did you only re-installed the DB or made a full reinstall ?

Can you precise where is your mount and what protocol you use

Policies are used widely to provide permissions on the file but also on the various APIs, have you tried to remove the “deny” policies you added to see which one is problematic ?

Could you please give more details about you installation (version of cells and the DB at least) ?

Unfortunately I was unable to resolve this issue by getting into hideo to remove any deny rights.
As I said before even the admin user password were considered unauthorized at the login.
What I want up having to do is wiping everything out it’s starting from scratch,
I dropped the database, create a new database, removed all folders from the working directory, deleted the pydio.json file, then brought everything back up.
Reset the admin password via the c l i, then started repopulating my work spaces.

In addition to this question,
Could you tell me how to add a data source?
When we try to add a data source, we put in the path where we want the data source to be (on a network share) however we are unable to save that configuration do you save button is completely great out.

I am not sure I understand you correctly here (please, don’t get offended, but are you using some automated translation tool?)
But it seems that in the end you could solve your problem and log again on the web UI with the admin user, right ?

Usually when the save button stays “greyed out” it means that one of the compulsory parameter has not been entered or is not valid.
I could not tell much more without the details I asked in my previous message, but quickly said:

  • some network share protocol are not fully supported
  • you must not try to create a DS at the root of a mount, this cannot work.

Not offended at all…was driving and using text to speech.,…sorry about that.
Let me clarify
Unfortunately I was unable to resolve this issue by getting into Pydio remove any deny rights.
As I said before, even the admin user password was considered unauthorized at the login page
What I wound up having to do is wiping everything out and starting from scratch,
I dropped the database, created a new database, removed all folders from the working directory, deleted the pydio.json file, then brought everything back up.
Reset the admin password via the c l i, then started repopulating my work spaces.

The path to the DS would be
/media/pydio/pydiods1/clients
I have a mount point in media pointing to my fileserver where the working directory is. /media/pydio is the mount /pydiods1/clients/ is the path I would like to create the DS in.

If I understand correctly, (please correct me if/where I am wrong)

  • your mount is at /media/pydio (typically you have a folder /media/pydio/lost+found )
  • you have defined you CELLS_WORKING_DIR to be at /media/pydio, typically you main config file is at /media/pydio/pydio.log
  • your instance is working (you can login as admin)
  • your default datasources (typically pydiods1) are under /media/pydio/data/
  • you want to create additional datasources at /media/pydio/pydiods1/clients

I am quite sure at least one of the assertion above does not fit your setup, would be nice to know which one to be able to help.

By the way, you still haven’t tell the kind of network share you use.

I got all this working with no problem or issues.
However I do have one more question if you could assist.
I am trying to get Collaboro to work, I followed the instructions for installing via Docker and have Code running,
I cannot seem to open the docks via the reverse proxy using Nginx.
any ideas?