Login Failed with invalid request

Running Pydio cells on Ubuntu behind nginx reverse proxy. Prior to reverse proxy, Authentication worked fine, Had to move to reverse proxy because of security tagging. Anyway, now we are behind nginx and cannot authenticate. I get the error
Info “Login failed with {“id”:”",“code”:0,“detail”:“invalid_request”,“status”:""}"
ERROR pydio.rest.frontend Rest Error 401 {“error”: “{“id”:“login.failed”,“code”:401,“detail”:“Login failed”,“status”:“Unauthorized”}”}

I’m kind of stuck at this point.
I’ve gone through this forum and not seen anything that can help. Not using Docker. I see a couple of threads but they’ve been closed with no info on how to fix the issue.

Nginx conf
upstream Servername{
server x.x.x.21:8080;
}

server {
server_name share.comp.com;

    location / {
       proxy_pass http://x.x.x.21:8080;
       grpc_pass grpcs://x.x.x.21:8080;
 }

    location /ws/ {
    proxy_pass https://x.x.x.21:8080;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "Upgrade";
 }

error_log /var/log/nginx/cells-proxy-error.log;
access_log /var/log/nginx/cells-proxy-access.log;

listen [::]:443 ssl ipv6only=on; # managed by Certbot
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/share.comp.com/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/share.comp.com/privkey.pem; # managed by Certb>
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
if ($host = share.comp.com) {
return 301 https://$host$request_uri;
} # managed by Certbot

    server_name share.comp.com;
    return 404; # managed by Certbot

}

Hi,

Try to change the proxy_pass & add two proxy header setting

location / {
                proxy_pass http://x.x.x.21:8080$request_uri;
                proxy_pass_request_headers on;
                proxy_set_header Host $host;
                proxy_set_header X-Real-IP $remote_addr;

Turned out to be a 443 error. Thank you for the help.

hi,
After moving to reverse proxy, did you ./cells configure sites to change url ?